#13906 closed bug (fixed)

WebPositive and FFmpeg 3.4 on x86_gcc2

Reported by: Lan72 Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: - General Version: R1/Development
Keywords: FFmpeg, WebPositive Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

WebPositive falls when playing video on Youtube and other videohostings when FFmpeg 3.4 is installed on 32-bit Hybrid. This problem has been observed for a long time. QMPlay2 also fails with an error "QMPlay2 crashed (SIGILL) Illegal instruction".

I can be mistaken, but for some reason I think that the emergency crash of these programs have the same reason.

All other multimedia programs, including MediaPlayer and Qmmp, work normally.

This problem is not observed when the FFmpeg of 3.2 release branch is installed (3.2.4 - 3.2.9).

Attachments (1)

WebPositive-37618-debug-25-12-2017-12-22-31.report (48.5 KB) - added by Lan72 18 months ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 18 months ago by Lan72

Has a Patch: set

comment:2 Changed 18 months ago by pulkomandy

Has a Patch: unset

comment:3 Changed 18 months ago by diver

What about x86_64 Haiku with FFmpeg 3.4?

comment:4 Changed 17 months ago by Lan72

The problem is solved after building FFmpeg 3.4.1 with a new recipe that contains interesting innovations.

Excellent work as WebPositive, and the above-mentioned video player QMPlay2!

Many thanks to PulkoMandy, as well as to all others who participated in the development of the new recipe.

Last edited 17 months ago by Lan72 (previous) (diff)

comment:5 Changed 17 months ago by pulkomandy

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.