#13909 closed bug (duplicate)

due DHCP, custom DNS are overridden (settings not persistent)

Reported by: Giova84 Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Network & Internet Version: R1/Development
Keywords: Cc:
Blocked By: #6351 Blocking:
Has a Patch: no Platform: All

Description

haiku hrev 51706 gcc2h.

I set custom DNS in the network preflet (and so in the resolv.conf file), and the ethernet card is managed by DHCP; if I detach and reattach the eth cable (or when I reboot Haiku) DHCP take the DNS fro the router, overridding my custom DNS.

Change History (4)

comment:1 Changed 19 months ago by mmlr

That is what is supposed to happen. DNS settings are (or at least can be) part of what is configured by DHCP. Otherwise using DHCP would be rather frustrating as you'd still have to always configure DNS manually.

comment:2 Changed 19 months ago by Giova84

Sure, you're right. But IMHO, DHCP should only write DNS in the resolv.conf file if not present or if is empty (read: not override if custom DNS are already presents); so this ticket should be edit as enhancement?

comment:3 Changed 10 months ago by IIsi50MHz

Duplicate of #6351

comment:4 Changed 10 months ago by humdinger

Blocked By: 6351 added
Resolution: duplicate
Status: newclosed

Thanks!

Note: See TracTickets for help on using tickets.