Opened 22 months ago

Closed 21 months ago

Last modified 21 months ago

#13929 closed bug (fixed)

PowerStatus no longer runs.

Reported by: bbjimmy Owned by: tqh
Priority: normal Milestone: Unscheduled
Component: Drivers/ACPI Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by diver)

hrev51722 running on my eeepc, Power status no longer runs. To get some feedback, I launched power status from the command line and selected "Run in window".

The following returned:

/system/apps/PowerStatus
try /dev/power/acpi_battery/0
try /dev/power/button/power
try /dev/power/button/power_fixed
try /dev/power/button/sleep
No power interface found.

Change History (8)

comment:1 by diver, 22 months ago

Component: - GeneralDrivers/ACPI
Description: modified (diff)
Owner: changed from nobody to tqh
Status: newassigned

comment:2 by leszek, 22 months ago

I can confirm this on my Lenovo 3000 N200 Notebook. Power Status does not show anything useful anymore. It was working fine before.

Last edited 22 months ago by leszek (previous) (diff)

comment:3 by Begasus, 22 months ago

Can confirm too (running in VirtualBox) https://ibb.co/hNpTPw

comment:4 by tqh, 22 months ago

No need to report more at the moment, some machines seems to have problem with this version of ACPI. At least one worked with the same locking before the ACPI upgrade, so either a upgrade or downgrade, or a missing piece in our integration will fix this. Hopefully no biggie..

comment:5 by tqh, 21 months ago

Tested gcc2_x86 but with a newer ACPI and there seems to be quite interesting failure, ACPI path gets truncated:

KERN: ACPI Error: AE_BAD_PARAMETER, Returned by Handler for [EmbeddedControl]KERN:  (20180105/evregion-425)
KERN: ACPI Error: Method parse/execution failed KERN: \_SB.PCI0.LPCB.EC0.SMBRKERN: , AE_BAD_PARAMETERKERN:  (20180105/psparse-677)
KERN: ACPI Error: Method parse/execution failed KERN: \_SB.PCI0.LPCB.EC0.BIF9KERN: , AE_BAD_PARAMETERKERN:  (20180105/psparse-677)
KERN: ACPI Error: Method parse/execution failed KERN: \_SB.PCI0.BAT0._BIFKERN: , AE_BAD_PARAMETERKERN:  (20180105/psparse-677)
KERN: module: Search for drivers/power/acpi_embedded_controller/device_v1 failed.
KERN: ACPI Error: AE_BAD_PARAMETER, Returned by Handler for [EmbeddedControl]KERN:  (20180105/evregion-425)
KERN: ACPI Error: Method parse/execution failed KERN: \_SB.PCI0.LPCB.EC0.SMBRKERN: , AE_BAD_PARAMETERKERN:  (20180105/psparse-677)
KERN: ACPI Error: Method parse/execution failed KERN: \_SB.PCI0.LPCB.EC0.BIF9KERN: , AE_BAD_PARAMETERKERN:  (20180105/psparse-677)
KERN: ACPI Error: KERN: Method parse/execution failed KERN: \_SB.PCI0.BAT0._BIFKERN: , AE_BAD_PARAMETER (20180105/psparse-677)
KERN: module: Search for drivers/power/acpi_embedded_controller/device_v1 failed.

_SB should be _SB_. This only happens on x86 though. Should not be that hard to track down. It would also explain some 32 bit shutdown problems.

Can someone with this issue search their syslog for ACPI Error: and confirm that it is in current ACPI code as well.

comment:6 by leszek, 21 months ago

Yes this is the exact error I also found in my syslog:

KERN: ACPI Error: Method parse/execution failed [\_SB.PCI0.LPCB.BAT1._BST] (Node 0x82972138), AE_BAD_PARAMETER (20170303/psparse-668)
KERN: ACPI Error: KERN: Method parse/execution failed KERN: [\_SB.PCI0.LPCB.BAT1._BST] (Node 0x82972138)KERN: , AE_BAD_PARAMETERKERN:  (20170303/psparse-668)

comment:7 by tqh, 21 months ago

Resolution: fixed
Status: assignedclosed

Should be fixed in hrev51771.

comment:8 by bbjimmy, 21 months ago

It would be nice if I could update my install to test this. That won't happen until  https://dev.haiku-os.org/ticket/13937 is fixed.

Note: See TracTickets for help on using tickets.