Opened 2 years ago

Closed 16 months ago

#13955 closed bug (fixed)

Haiku x86_64 won't boot past the grub menu

Reported by: HAL Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: System/Kernel Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86-64

Description

Cannot boot hrev51727 version anymore. Before that I could boot 51724. It crashes from booting just after I press enter on grub Haiku menu entry. I don't even see the horizontal boot icons start to light up and no horizontal boot icons visible. The same Haiku version on GCC2 boots properly.

Attachments (1)

IMG_20180115_123248.jpg (1.2 MB ) - added by HAL 2 years ago.
Last page of screen output during boot

Download all attachments as: .zip

Change History (14)

comment:1 by waddlesplash, 2 years ago

Cc: HAL removed
Component: System/runtime_loaderSystem/Kernel
Keywords: x86_64 boot fails removed
Owner: changed from nobody to korli
Status: newassigned

comment:2 by korli, 2 years ago

Owner: changed from korli to nobody

I looked at hrev51726 and hrev51727, can't see how they could lead to a regression.

by HAL, 2 years ago

Attachment: IMG_20180115_123248.jpg added

Last page of screen output during boot

comment:3 by HAL, 2 years ago

I tried to photograph all the screen pages during boot but had trouble with finger input to phone screen. I don't know if this photo will be any use. Instead of system crashing back to BIOS screen at pressing enter after that page, it seemed to freeze (capslock light would not function, numlock nonfunctioning, ctrl + alt + delete) had to use reset button.

comment:4 by korli, 2 years ago

Seems you have enabled "Enable on screen debug output". You can also try "Disable on screen paging" and see if you get more output.

comment:5 by HAL, 2 years ago

I did disable on screen paging. It booted right to the desktop. I'm writing this from hrev51727 now. It always boots with crash to desktop from normal boot ie no intermittant bug. Should I take a video of the screen with paging disabled? Could the file be uploaded?

comment:6 by HAL, 2 years ago

Now since I turned off paging during boot and was able to boot to a functioning desktop, that seems to have cured the problem. I don't even need debug mode now to boot. Just a normal boot. Don't know how that can happen.

comment:7 by HAL, 2 years ago

I bug always happens after I have booted into other OS Linux. When I reboot to Haiku it is back. Just rebooting from Haiku into Haiku it is gone. When bug comes back I have to boot into debug mode first, disable paging for screen output. That cures it for a reboot from Haiku to Haiku.

comment:8 by HAL, 2 years ago

Also shuting down from Haiku and booting back into Haiku the bug does not appear.

comment:9 by HAL, 2 years ago

hrev51795 has not had any problem booting. I have booted from Linux to Haiku and Haiku to Haiku over 2 sessions. I think the bug has gone.

comment:10 by korli, 2 years ago

I know that hrev51789 could have "solved" some bad behavior when the BIOS lets x2apic enabled on boot. Just a guess.

comment:11 by HAL, 2 years ago

I cannot find any x2apic setting in the BIOS. The mainboard is Gigabyte ga-b85m d3h.

Last edited 2 years ago by HAL (previous) (diff)

comment:12 by korli, 2 years ago

It's not a bios setting. In the syslog is written whether x2apic is used.

comment:13 by waddlesplash, 16 months ago

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.