Opened 15 months ago

Closed 6 months ago

#13955 closed bug (fixed)

Haiku x86_64 won't boot past the grub menu

Reported by: HAL Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: System/Kernel Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86-64

Description

Cannot boot hrev51727 version anymore. Before that I could boot 51724. It crashes from booting just after I press enter on grub Haiku menu entry. I don't even see the horizontal boot icons start to light up and no horizontal boot icons visible. The same Haiku version on GCC2 boots properly.

Attachments (1)

IMG_20180115_123248.jpg (1.2 MB) - added by HAL 15 months ago.
Last page of screen output during boot

Download all attachments as: .zip

Change History (14)

comment:1 Changed 15 months ago by waddlesplash

Cc: HAL removed
Component: System/runtime_loaderSystem/Kernel
Keywords: x86_64 boot fails removed
Owner: changed from nobody to korli
Status: newassigned

comment:2 Changed 15 months ago by korli

Owner: changed from korli to nobody

I looked at hrev51726 and hrev51727, can't see how they could lead to a regression.

Changed 15 months ago by HAL

Attachment: IMG_20180115_123248.jpg added

Last page of screen output during boot

comment:3 Changed 15 months ago by HAL

I tried to photograph all the screen pages during boot but had trouble with finger input to phone screen. I don't know if this photo will be any use. Instead of system crashing back to BIOS screen at pressing enter after that page, it seemed to freeze (capslock light would not function, numlock nonfunctioning, ctrl + alt + delete) had to use reset button.

comment:4 Changed 15 months ago by korli

Seems you have enabled "Enable on screen debug output". You can also try "Disable on screen paging" and see if you get more output.

comment:5 Changed 15 months ago by HAL

I did disable on screen paging. It booted right to the desktop. I'm writing this from hrev51727 now. It always boots with crash to desktop from normal boot ie no intermittant bug. Should I take a video of the screen with paging disabled? Could the file be uploaded?

comment:6 Changed 15 months ago by HAL

Now since I turned off paging during boot and was able to boot to a functioning desktop, that seems to have cured the problem. I don't even need debug mode now to boot. Just a normal boot. Don't know how that can happen.

comment:7 Changed 14 months ago by HAL

I bug always happens after I have booted into other OS Linux. When I reboot to Haiku it is back. Just rebooting from Haiku into Haiku it is gone. When bug comes back I have to boot into debug mode first, disable paging for screen output. That cures it for a reboot from Haiku to Haiku.

comment:8 Changed 14 months ago by HAL

Also shuting down from Haiku and booting back into Haiku the bug does not appear.

comment:9 Changed 14 months ago by HAL

hrev51795 has not had any problem booting. I have booted from Linux to Haiku and Haiku to Haiku over 2 sessions. I think the bug has gone.

comment:10 Changed 14 months ago by korli

I know that hrev51789 could have "solved" some bad behavior when the BIOS lets x2apic enabled on boot. Just a guess.

comment:11 Changed 14 months ago by HAL

I cannot find any x2apic setting in the BIOS. The mainboard is Gigabyte ga-b85m d3h.

Last edited 14 months ago by HAL (previous) (diff)

comment:12 Changed 14 months ago by korli

It's not a bios setting. In the syslog is written whether x2apic is used.

comment:13 Changed 6 months ago by waddlesplash

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.