Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#14060 closed bug (duplicate)

WebPositive crashes on open with "invalid opcode exception"

Reported by: bradsco Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: - General Version: R1/Development
Keywords: Cc:
Blocked By: #10304 Blocking:
Platform: x86

Description

Opening WebPositive results in an error dialog. No main window is displayed.

Attachments (1)

WebPositive-614-debug-28-03-2018-06-42-20.report (18.4 KB ) - added by bradsco 2 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 by diver, 2 years ago

IIRC HaikuWebKit requires SSE2 which Pentium III doesn't have.

comment:2 by korli, 2 years ago

Platform: Allx86

comment:3 by pulkomandy, 2 years ago

Blocked By: 10304 added
Resolution: duplicate
Status: newclosed

Duplicate of #10304.

There was a regression in the latest release but it will be fixed again in the next one (already done in webkit sources).

comment:4 by R0bur, 2 years ago

"... it will be fixed again in the next one" 27.04.2018 - issue is actual for now.

comment:5 by pulkomandy, 2 years ago

Yes, still didn't make a WebKit release since then.

comment:6 by R0bur, 2 years ago

I think that WebKit will not patch this issue. They are right: P-III is deprecated CPU. Maybe there is an ability to modify WebPositive to disable multimedia features when running on the old hardware?

comment:7 by cb88, 2 years ago

See here this was discussed at length on the mailing list already. https://www.freelists.org/post/haiku-development/Fwd-webkitdev-Proposal-Not-supporting-x86-wo-SSE2,8

It is unlikely that webkit will have SSE patched out, most likely is that Netsurf will be bundled for older machines instead of Webpositive it is also a rather nice browser with a native interface though not as featureful as Webpositive.

comment:8 by pulkomandy, 2 years ago

It's not just about multimedia features. WebKit needs SSE support also for the javascript code they generate, and I'm not going to spend much effort avoiding that.

in reply to:  8 comment:9 by R0bur, 2 years ago

Replying to pulkomandy, cb88: Thank you for the clarification of the issue.

Note: See TracTickets for help on using tickets.