Opened 11 months ago

Closed 2 weeks ago

#14096 closed bug (duplicate)

USB mouse stops working when moving mouse during haiku start up

Reported by: andreas_dr Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Drivers/USB/XHCI Version: R1/Development
Keywords: Cc:
Blocked By: #13767 Blocking:
Has a Patch: no Platform: All

Description

This sounds strange, but it really happens from time to time. If I am moving mouse during haiku start up (shortly after app server started and still busy loading) my USB mouse stops working.

If you need any additional information do not hesitate to ask.

Attachments (2)

haiku-51883-syslog-usb-bug.txt.txt (364.9 KB) - added by andreas_dr 11 months ago.
syslog (119.0 KB) - added by cocobean 11 months ago.
Syslog: Computer using AMD IXP SB4x0 USB Host controller

Download all attachments as: .zip

Change History (12)

comment:1 Changed 11 months ago by korli

Component: - GeneralDrivers/USB/XHCI

comment:2 Changed 11 months ago by mmlr

Please attach a syslog, found in /var/log, to the ticket. It may show what is going on. Also, what revision of Haiku did you encounter this with?

Changed 11 months ago by andreas_dr

comment:3 Changed 11 months ago by andreas_dr

Hi,

its even reproducable. I have this issue with rev 51883 and older revisions.

Many thanx and

Best regards Andras

comment:4 Changed 11 months ago by andreas_dr

BTW. The whole usb stack seems to be stuck then.

comment:5 Changed 11 months ago by mmlr

It looks like some transfers time out and they are not correctly retired/cleaned up inside the XHCI bus driver. This then leads to a state where the maximum number of concurrent active transfers is reached and no further transfers can be scheduled. This is probably an missing/incomplete or buggy error code path.

Changed 11 months ago by cocobean

Attachment: syslog added

Syslog: Computer using AMD IXP SB4x0 USB Host controller

comment:6 Changed 11 months ago by cocobean

Confirmed with hrev51894 x86 using AMD SB4x0 host controller (see syslog). I used a PS/2 mouse which works, USB mouse and no USB stick will mount on this system (confirming USB stack seems inop after desktop appears).

~> uname -a

Haiku shredder 1 hrev51894 Apr 22 2018 17:05:26 BePC x86 Haiku

~> listimage |grep driver

2817 0xddd61000 0xddd63000 0 0 /boot/system/add-ons/kernel/drivers/dev/bus/usb_raw

->listdev

device Serial bus controller (USB controller, EHCI) [c|3|20]

vendor 1002: Advanced Micro Devices, Inc. [AMD/ATI] device 4373: IXP SB4x0 USB2 Host Controller

device Serial bus controller (USB controller, OHCI) [c|3|10]

vendor 1002: Advanced Micro Devices, Inc. [AMD/ATI] device 4375: IXP SB4x0 USB Host Controller

device Serial bus controller (USB controller, OHCI) [c|3|10]

vendor 1002: Advanced Micro Devices, Inc. [AMD/ATI] device 4374: IXP SB4x0 USB Host Controller

~> listusb

0000:0000 /dev/bus/usb/0/hub "HAIKU Inc." "OHCI RootHub" ver. 0110

0000:0000 /dev/bus/usb/1/hub "HAIKU Inc." "OHCI RootHub" ver. 0110

0000:0000 /dev/bus/usb/2/hub "HAIKU Inc." "EHCI RootHub" ver. 0200

Last edited 11 months ago by cocobean (previous) (diff)

comment:7 Changed 11 months ago by mmlr

Component: Drivers/USB/XHCIDrivers/USB
Owner: changed from nobody to mmlr

Ah yes, an SB400. The SB400/600 chipsets have always been problemantic. The syslog shows that there is an initial timeout that then gets things stuck and the USB drive ejected. These issues are usually related to undelivered interrupts, but it's hard to tell if this is the case here.

comment:8 Changed 4 weeks ago by waddlesplash

Component: Drivers/USBDrivers/USB/XHCI
Owner: changed from mmlr to nobody
Platform: x86-64All

That issue also looks entirely unrelated to the one in this ticket, which is definitely an XHCI bug.

comment:9 Changed 4 weeks ago by waddlesplash

Please retest under a recent nightly; quite a lot of XHCI issues were resolved recently.

comment:10 Changed 2 weeks ago by waddlesplash

Blocked By: 13767 added
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.