Opened 17 months ago

Closed 8 months ago

#14110 closed bug (not reproducible)

media_addon_server crash after update to hrev51897

Reported by: vidrep Owned by: Barrett
Priority: normal Milestone: Unscheduled
Component: Servers/media_addon_server Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Updated from hrev51894 to hrev51897 x86_gcc2h After reboot, media_addon_server crashes as soon as Desktop is running. Audio device appears to not be detected any more. Debug report and syslog attached 64 bit appears to be OK affer update, so only a gcc2h problem

Attachments (3)

media_addon_server_syslog.txt (1.8 KB ) - added by vidrep 17 months ago.
media_addon_server-783-debug-24-04-2018-23-05-02.report (23.7 KB ) - added by vidrep 17 months ago.
syslog (346.7 KB ) - added by vidrep 17 months ago.

Download all attachments as: .zip

Change History (7)

by vidrep, 17 months ago

by vidrep, 17 months ago

Attachment: syslog added

comment:1 by vidrep, 17 months ago

This morning I did a clean install of hrev51897 x86_gcc2h using a RAW image. After a SoftwareUpdate to hrev51898, the media_addon_server has not crashed yet. Please keep the issue open, and I'll monitor the situation for a few days.

Last edited 17 months ago by vidrep (previous) (diff)

comment:2 by waddlesplash, 14 months ago

This looks like the flattened BMessage is corrupt, and somehow it's not getting validated properly. If it happens again, please copy the media_addon_server settings file and upload it here.

comment:3 by vidrep, 14 months ago

I have not had a media_addon_server crash since my last comment 3 months ago.

comment:4 by waddlesplash, 8 months ago

Resolution: not reproducible
Status: newclosed
Note: See TracTickets for help on using tickets.