#14113 closed bug (duplicate)

WebPositive doesn't show icons on discuss.haiku-os.org

Reported by: R0bur Owned by: pulkomandy
Priority: normal Milestone: Unscheduled
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: #13117 Blocking:
Has a Patch: no Platform: All

Description


Attachments (2)

webpositive.png (14.8 KB) - added by R0bur 13 months ago.
https://discuss.haiku-os.org/ - navigation icons are missing.
otterbrowser.png (21.8 KB) - added by R0bur 13 months ago.
"Otter-Browser" displays images while "WebPositive" doesn't.

Download all attachments as: .zip

Change History (6)

Changed 13 months ago by R0bur

Attachment: webpositive.png added

https://discuss.haiku-os.org/ - navigation icons are missing.

comment:1 Changed 13 months ago by pulkomandy

Install the fontawesome font (it is in HaikuDepot) to get back some of these icons. The problem is lack for support for web fonts (not easily done because of the way app_server handles fonts).

comment:2 Changed 13 months ago by R0bur

I've installed "fontawesome", rebooted Haiku, but issue still exist for the site "https://discuss.haiku-os.org/". Maybe "search" icon is lack in the font?

WebPositive doesn't support embedded fonts...

<link rel="preload" href="/assets/fontawesome-webfont-2adefcbc041e7d18fcf2d417879dc5a09997aa64d675b7a3c4b6ce33da13f3fe.woff2?https://discuss.haiku-os.org&2&v=4.7.0" as="font" type="font/woff2" crossorigin />

...because app_server fonts interface complexity?

Changed 13 months ago by R0bur

Attachment: otterbrowser.png added

"Otter-Browser" displays images while "WebPositive" doesn't.

comment:3 Changed 13 months ago by pulkomandy

Summary: WebPositive doesn't show some webpage elements.WebPositive doesn't show icons on discuss.haiku-os.org

comment:4 Changed 11 months ago by pulkomandy

Blocked By: 13117 added
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.