#14118 closed bug (duplicate)

KDL while running WebKit testsuite: vnode->advisory_locking == __null

Reported by: pulkomandy Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: System/Kernel Version: R1/Development
Keywords: Cc:
Blocked By: #14121 Blocking:
Has a Patch: no Platform: All

Description

I hit this panic reproductibly while running the WebKit test suite.

If I interpret things properly:

  • The vnode is being freed by the low resource handler because it is unused,
  • But, its advisory_locking is unexpectedly not null
  • The team that supposedly holds the lock seems to be gone.

Attachments (1)

DSC_0004.JPG (291.2 KB) - added by pulkomandy 15 months ago.
screenshot of short debug session

Download all attachments as: .zip

Change History (3)

Changed 15 months ago by pulkomandy

Attachment: DSC_0004.JPG added

screenshot of short debug session

comment:1 Changed 15 months ago by pulkomandy

Summary: vnode->advisory_locking == __nullKDL while running WebKit testsuite: vnode->advisory_locking == __null

comment:2 Changed 15 months ago by pulkomandy

Blocked By: 14121 added
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.