Opened 15 months ago

Closed 15 months ago

Last modified 15 months ago

#14123 closed bug (fixed)

Gerrit and https://git.haiku-os.org/haiku down

Reported by: korli Owned by: kallisti5
Priority: normal Milestone:
Component: Website/Gerrit Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

git pull --rebase
fatal: internal server error
remote: internal server error 
fatal: protocol error: bad pack header
An error occurred while reading CGI reply (no response received)

Change History (3)

comment:1 Changed 15 months ago by kallisti5

Yeah, jessicah and a few others have mentioned similar issues popping up recently. I have a Gerrit upgrade queued, i'm going to go ahead and bring all the services down and up this morning (which should also apply the update)

Stand by

comment:2 Changed 15 months ago by kallisti5

Resolution: fixed
Status: newclosed

Resolved.

We encountered some corruption of the git repositories. I think the random disconnects people are reporting were the cause? Gerrit wrote out an incomplete pack file and corrupted the repo.

I recovered the health of the repository thanks in part to help from Pulkomandy. I've documented what happened and the resolution here: https://github.com/haiku/infrastructure/blob/master/docs/git-pack-corruption.md

As for the corruption, I did a git gc which seems to have sped up repository access. I also upgraded Gerrit to 2.15 Lets hope those steps resolve the issue for good.

comment:3 Changed 15 months ago by kallisti5

btw.. gerrit is showing a 500 server error when you access it. I'm asking the Gerrit devs now about it... seeing a generic java error. Not sure of cause at this time and the Gerrit dev channel seems pretty dead :-|

Note: See TracTickets for help on using tickets.