Opened 15 months ago

Last modified 5 months ago

#14145 new enhancement

Realtek High Definition Audio Codec driver support

Reported by: cocobean Owned by: korli
Priority: normal Milestone: R1/beta2
Component: Drivers/Audio/HDA Version: R1/Development
Keywords: realtek Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Conexant / Realtek HD Codec driver support for: ALC1150, ALC880, ALC882, ALC883, ALC885, ALC888, ALC889, ALC892, ALC898, ALC861, ALC861VD, ALC660, ALC260, ALC262, ALC267, ALC268, ALC269, ALC272

Newer: ALC1250 and S1220A (optional)

Ref: http://www.realtek.com http://www.realtek.com/products/productsView.aspx?Langid=1&PNid=24&PFid=28&Level=5&Conn=4

Change History (8)

comment:1 in reply to:  description Changed 15 months ago by cocobean

Last edited 15 months ago by cocobean (previous) (diff)

comment:2 Changed 15 months ago by waddlesplash

Milestone: R1/beta1

comment:3 Changed 10 months ago by pulkomandy

Milestone: R1/beta2

comment:4 Changed 5 months ago by devport

Hey I have notebook acer 257 and sound card Realtek ALC269. Im no sound in speakers and headphones. Haiku detect the card: HD Audio in channel 0

Outputs can be adjusted with sliders, and MediaPlayer playing music, but i have no sound.

comment:5 Changed 5 months ago by cocobean

Last edited 5 months ago by cocobean (previous) (diff)

comment:6 Changed 5 months ago by cocobean

@devport - Yes, I listed that audio chip. A fix is planned for R1/B2 per ticket info.

comment:7 Changed 5 months ago by devport

If you have code / idea this problem, willingly i read source and testing in my card. My hobby is programming. Mayby driver(controller) not support ICH7 (in linux driver this chip is checked "OLD"), but codec functionally on this controller in my notebook. Sorry my english is not good :) I from Poland.

Last edited 5 months ago by devport (previous) (diff)

comment:8 Changed 5 months ago by cocobean

@devport - I found a bug which periodically doesn't initially initialize the sound chip upon bootup to desktop. The HDA driver works for me otherwise - so usually I'd think it just doesn't recognize your sound chip.

Korli will probably update the HDA driver when he has the time. Check your BIOS revision (I think the recent one is rev. 1.15 for your laptop) and ensure your sound chip works fine when testing other OSes (i.e. Linux, FreeBSD, Win, etc).

Note: See TracTickets for help on using tickets.