Opened 11 months ago

Closed 11 months ago

Last modified 11 months ago

#14153 closed bug (fixed)

Haiku install ISO drops into KDL right after the splash screen

Reported by: accessays Owned by: korli
Priority: high Milestone: R1/beta1
Component: Drivers/Network Version: R1/Development
Keywords: kdl Cc:
Blocked By: Blocking: #14152
Has a Patch: no Platform: x86

Description

Right after the splash screen finishes loading, Haiku shows mouse cursor for a second and then drops into KDL with the following error message: PANIC: device_set_driver: method bus_get_dma_tag not found

Attachments (1)

serial-out.txt (125.9 KB) - added by accessays 11 months ago.
Serial output from the virtual machine.

Download all attachments as: .zip

Change History (8)

Changed 11 months ago by accessays

Attachment: serial-out.txt added

Serial output from the virtual machine.

comment:1 Changed 11 months ago by accessays

FYI, running it in VMware 14.1.1 build-7528167. 40 GB HDD, 4GB RAM, 2 cores. I've tested several previous hrevs, up to hrev51944 (the very previous one). This only occurs on hrev51947. hrev51947 seems to be only style fixes, so it's probably hrev51945 or hrev51946.

comment:2 Changed 11 months ago by accessays

Looking through those hrevs, it seems like hrev51946 is the culprit. It changed some networking things, which causes device_set_driver to panic (http://xref.plausible.coop/source/xref/haiku/src/libs/compat/freebsd11_network/compat.c#320).

comment:3 Changed 11 months ago by pulkomandy

Component: DriversDrivers/Network
Owner: changed from nobody to korli
Status: newassigned

comment:4 Changed 11 months ago by korli

Should be fixed in hrev51951.

comment:5 Changed 11 months ago by cocobean

Confirmed as fixed with hrev51952.

comment:6 Changed 11 months ago by korli

Resolution: fixed
Status: assignedclosed

Thank for the feedback. Victor, if not fixed please reopen.

comment:7 Changed 11 months ago by korli

Blocking: 14152 added
Note: See TracTickets for help on using tickets.