Opened 4 months ago

Closed 2 months ago

#14171 closed bug (no change required)

Emacs not inheriting PATH properly from calling shell

Reported by: tidux Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Applications Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Emacs is unable to locate the Git binary, which is installed as /bin/git and works when called manually, even from M-x shell inside emacs. This can be reproduced as follows:

git clone https://github.com/syl20bnr/spacemacs ~/.emacs.d && emacs

I have attached a screenshot of the observed output. The correct output would be the packages installing and returning to the Spacemacs home buffer.

Attachments (1)

PATH-errors.png (86.9 KB) - added by tidux 4 months ago.
Emacs misbehaving under libvirt/KVM

Download all attachments as: .zip

Change History (4)

Changed 4 months ago by tidux

Attachment: PATH-errors.png added

Emacs misbehaving under libvirt/KVM

comment:1 Changed 4 months ago by korli

Looks like a HaikuPorts issue.

comment:2 Changed 2 months ago by tidux

Fixed in Emacs 26.1 in Haikuports. This can be closed.

comment:3 Changed 2 months ago by diver

Resolution: no change required
Status: newclosed
Note: See TracTickets for help on using tickets.