#14185 closed bug (invalid)

KDL: SMAP violation (XHCI)

Reported by: waddlesplash Owned by: korli
Priority: critical Milestone: R1/beta1
Component: Drivers/USB/XHCI Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by waddlesplash)

Just pkgman full-sync'd to latest (hrev51988?) and got this on boot. Real hardware (Lenovo ThinkPad E550).

Attachments (1)

XHCI_KDL.jpg (386.6 KB) - added by waddlesplash 14 months ago.

Download all attachments as: .zip

Change History (4)

Changed 14 months ago by waddlesplash

Attachment: XHCI_KDL.jpg added

comment:1 Changed 14 months ago by waddlesplash

Description: modified (diff)

comment:2 Changed 14 months ago by korli

Unfortunately this one is odd: the usb stack allocates kernel mapped memory: https://git.haiku-os.org/haiku/tree/src/add-ons/kernel/bus_managers/usb/PhysicalMemoryAllocator.cpp#n79 The reason SMAP is triggered is that a page descriptor for the involved kernel page has the user flag set. Because it happens on boot, there can't really be a userland process involved (I think). Does it happen every time?

The bug would need to be reproduced and more data dumped (areas for instance).

comment:3 Changed 14 months ago by waddlesplash

Resolution: invalid
Status: assignedclosed

As it turned out, I had an old usb bus manager in my non-packaged that was from before your fix to it. Removing it solved the issue.

Note: See TracTickets for help on using tickets.