#14189 closed bug (no change required)

The system is not updated to the latest version

Reported by: Lan72 Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: - General Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I have installed Hajku x86_gcc2.

Since version hrev51972 the system has ceased to be updated to the latest version. Instead, only three components are proposed for updating: haiku_loader, makefile_engine and Webpositive (see screenshot).

What could be the problem?

Attachments (1)

screenshot1.jpeg (22.7 KB ) - added by Lan72 16 months ago.

Download all attachments as: .zip

Change History (7)

by Lan72, 16 months ago

Attachment: screenshot1.jpeg added

comment:1 by Lan72, 16 months ago

Last edited 16 months ago by Lan72 (previous) (diff)

comment:2 by diver, 16 months ago

Some packages prevent your system from being updated. You need to run pkgman full-sync to check which package it might be.

Last edited 16 months ago by diver (previous) (diff)

comment:3 by cocobean, 16 months ago

Fast fix:

  1. Download a recent nightly image:

https://download.haiku-os.org/nightly-images/x86_gcc2_hybrid/haiku-nightly-hrev51991-x86_gcc2_hybrid-anyboot.zip

  1. Install to HD. Do not reformat partition/HD.
  1. Use SoftwareUpdater to check and install latest packages.

comment:4 by Lan72, 16 months ago

diver Thanks, this solution helped.

I had several packages, that I built in mid-May, which I needed to create LibreOffice_x86. They were tied to the now obsolete gcc_x86_fortran-5.4.0 and gcc_x86_syslibs-5.4.0.

cocobean The decision is good, but too radical. In fact, this is a reinstall of the system from scratch.

comment:5 by Lan72, 16 months ago

A big request to close the ticket, because the problem is solved.

comment:6 by diver, 16 months ago

Resolution: no change required
Status: newclosed
Note: See TracTickets for help on using tickets.