Opened 2 years ago

Last modified 4 months ago

#14205 new bug

Haiku not shutting down

Reported by: vidrep Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: - General Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description

hrev52013 x86_gcc2h

Shutdown...->Power off

System will begin shutdown but hang at the "Shutting down..." notification. No mouse or keyboard available.

Tested hrev52009 -working hrev52013 - not working

Syslog attached

Attachments (2)

syslog_no_shutdown (149.1 KB ) - added by vidrep 2 years ago.
listdev.txt (3.1 KB ) - added by vidrep 2 years ago.

Download all attachments as: .zip

Change History (15)

by vidrep, 2 years ago

Attachment: syslog_no_shutdown added

by vidrep, 2 years ago

Attachment: listdev.txt added

comment:1 by cocobean, 2 years ago

Reviewed with hrev52013 x86_64. Shutdown works my hardware. Specific to x86?

comment:2 by vidrep, 2 years ago

Narrowed it down further

hrev52009 - working

hrev52012 - not working

It isn't arch specific. It does it on both x86_gcc2h and x86_64, but on only one of my PC's.

comment:3 by waddlesplash, 2 years ago

hrev520010 & hrev520011 reverted in hrev52016, please retest after that.

comment:4 by vidrep, 2 years ago

After updating to hrev52017 the Dell PC still intermittently hangs on shutdown.

comment:5 by korli, 2 years ago

I'm confused. Is it correct to interpret that this issue isn't related to the reverted commits? Or the commits make the issue easier to reproduce?

comment:6 by cocobean, 2 years ago

Reviewed with hrev52084 x86_gcc2. Now happens on my HP laptop,

  1. shutdown -q : this hangs the machine. No mouse/keyboard. Have to power down machine.
  2. shutdown -r : this shutdowns (soft reboot) and reboots properly without issue.
  3. shutdown -s or shutdown from Desktop Menu GUI: Same issue as 1.

NOTE: No shutdown issues with hrev52084 x86_64. (different hardware/computer)

Last edited 2 years ago by cocobean (previous) (diff)

comment:7 by tqh, 22 months ago

This sounds like some process or driver hangs before shutdown is even called. Hard to debug without trying to capture info from KDL or logs.

I would also like to know if hrev52303 or later works better.

comment:8 by vidrep, 18 months ago

I updated to hrev52775 x86_64, and the Dell Optiplex 780 still hangs on shutdown.

comment:9 by vidrep, 9 months ago

Tried again today after updating to hrev53523. It's still not shutting down.

comment:10 by vidrep, 5 months ago

Tried with hrev53903 x86_64. Still hanging as before.

comment:11 by waddlesplash, 4 months ago

Can you enter KDL via the keyboard shortcut and get a backtrace?

comment:12 by vidrep, 4 months ago

No keyboard when it hangs.

comment:13 by waddlesplash, 4 months ago

The KDL shortcut often works, even if userland and input_server are hung, because it's handled in the PS/2 driver itself. If interrupts are disabled, then you're out of luck completely; but it's worth a shot if you have not tried it yet.

Note: See TracTickets for help on using tickets.