Opened 11 months ago

Closed 11 months ago

Last modified 11 months ago

#14229 closed bug (fixed)

Pootle password change does not work

Reported by: irtusb Owned by: jessicah
Priority: normal Milestone:
Component: Website/Pootle Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I receive the link, can access the page, but upon submit form says missing arguments, password is not changed.

this is firefox 60

Change History (5)

comment:1 Changed 11 months ago by nielx

After clicking on the reset button there is a http 402. That's a very odd error code...

HTTP402: PAYMENT REQUIRED - The server requires payment before continuing to process requests. (XHR)POST - https://i18n.haiku-os.org/pootle//pootle/accounts/password/reset/key/##############/

comment:2 Changed 11 months ago by nielx

The issue is the duplication of the /pootle prefix in the URL. Removing that and manually redoing the request works in changing the password.

Next step: figuring out where the duplication happens.

comment:3 Changed 11 months ago by nielx

Owner: changed from nielx to jessicah
Status: newassigned

Jessica is looking into a quick fix.

comment:4 Changed 11 months ago by jessicah

Resolution: fixed
Status: assignedclosed

Applied a redirect in the nginx config to workaround the bug in Pootle.

comment:5 Changed 11 months ago by kallisti5

Confirmed the password reset process now works. (I just reset my own password)

Note: See TracTickets for help on using tickets.