#14231 closed bug (fixed)

Intel HD Audio stopped working

Reported by: BlueSky Owned by: korli
Priority: normal Milestone: Unscheduled
Component: Drivers/Audio/HDA Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I have 64-bit Haiku running on an Acer Aspire 5315 laptop. Audio was working when I first installed Haiku. Recently, I noticed that audio was not working anymore. I did some tests booting with the old hrevs that I could select in the boot loader
Last working hrev: 51854
First not working hrev: 51874
Audio tests were done with wav file playback in Media-Player, BeAE and Audacious and several video files playback (mp4 and mov) in Media-Player.

Attachments (6)

listdev.txt (3.2 KB) - added by BlueSky 12 months ago.
Output of "listdev"
listimage.txt (1.7 KB) - added by BlueSky 12 months ago.
Output of "listimage | grep drivers"
syslog.txt (496.1 KB) - added by BlueSky 12 months ago.
Syslog
syslog (297.2 KB) - added by Yowane_Haku 10 months ago.
syslog
listdev (2.5 KB) - added by Yowane_Haku 10 months ago.
listdev
listimage (1.9 KB) - added by Yowane_Haku 10 months ago.
listimage

Download all attachments as: .zip

Change History (14)

Changed 12 months ago by BlueSky

Attachment: listdev.txt added

Output of "listdev"

Changed 12 months ago by BlueSky

Attachment: listimage.txt added

Output of "listimage | grep drivers"

Changed 12 months ago by BlueSky

Attachment: syslog.txt added

Syslog

comment:1 Changed 12 months ago by diver

Component: Audio & VideoDrivers/Audio/HDA
Owner: changed from nobody to korli
Platform: x86-64All

hrev51864 was the only change to hda driver between hrev51854 and hrev51874.

comment:2 Changed 12 months ago by waddlesplash

From the syslog:

KERN: HDA: Detected controller @ PCI:0:27:0, IRQ:22, type 8086/284b (1025/0136)

Which was indeed one of the IDs added in the commit:

+	{ PCI_VENDOR_INTEL, 0x284b, HDA_QUIRK_SNOOP },

If ALSA really has that and it works, why does adding it break our driver?

comment:3 Changed 12 months ago by korli

Sounds like I misread the list: 0x2668, 0x269a, 0x27d8, 0x284b, 0x293e, 0x3a3e, 0x3a6e shouldn't get the quirk.

See https://github.com/torvalds/linux/blob/master/sound/pci/hda/hda_intel.c#L2500 the quirk is not in AZX_DCAPS_INTEL_ICH but on others AZX_DCAPS_INTEL_*.

comment:4 Changed 12 months ago by korli

Resolution: fixed
Status: newclosed

Should be fixed with hrev52042.

comment:5 Changed 12 months ago by BlueSky

I have just updated to hrev52042 and sound is working again. Thanks to everyone involved for the quick bug fix.

comment:6 Changed 10 months ago by Yowane_Haku

Resolution: fixed
Status: closedreopened

No sound for me also on 64-bit Haiku hrev 52254 with Intel HD Audio. I will try to pinpoint in which hrev it stopped working.

Changed 10 months ago by Yowane_Haku

Attachment: syslog added

syslog

Changed 10 months ago by Yowane_Haku

Attachment: listdev added

listdev

Changed 10 months ago by Yowane_Haku

Attachment: listimage added

listimage

comment:7 Changed 10 months ago by Yowane_Haku

Turns out the issue is caused by Avidemux installation. For some reason even MediaPlayer outputted no sound with it installed. I will report at HaikuPorts, so please close the ticket =)

comment:8 Changed 10 months ago by waddlesplash

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.