#14243 closed bug (duplicate)

PANIC: vm_page_fault - usb explore while booting with a USB Logitech Unifying Receiver

Reported by: kneekoo Owned by: mmlr
Priority: critical Milestone: Unscheduled
Component: Drivers/USB/UHCI Version: R1/Development
Keywords: kernel panic usb explore logitech unifying receiver Cc:
Blocked By: #9118 Blocking:
Has a Patch: no Platform: x86

Description

Hello,

The USB Logitech Unifying Receiver produces this output when I connect it under Linux Mint:

Jul  5 02:33:22 Nicu-PC kernel: [111845.109469] usb 1-1: new full-speed USB device number 7 using xhci_hcd
Jul  5 02:33:22 Nicu-PC kernel: [111845.264806] usb 1-1: New USB device found, idVendor=046d, idProduct=c52b
Jul  5 02:33:22 Nicu-PC kernel: [111845.264809] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Jul  5 02:33:22 Nicu-PC kernel: [111845.264812] usb 1-1: Product: USB Receiver
Jul  5 02:33:22 Nicu-PC kernel: [111845.264814] usb 1-1: Manufacturer: Logitech
Jul  5 02:33:22 Nicu-PC kernel: [111845.331100] logitech-djreceiver 0003:046D:C52B.0009: hiddev2,hidraw6: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:14.0-1/input2
Jul  5 02:33:22 Nicu-PC kernel: [111845.469911] input: Logitech M525 as /devices/pci0000:00/0000:00:14.0/usb1/1-1/1-1:1.2/0003:046D:C52B.0009/0003:046D:4013.000A/input/input27
Jul  5 02:33:22 Nicu-PC kernel: [111845.470610] logitech-hidpp-device 0003:046D:4013.000A: input,hidraw7: USB HID v1.11 Mouse [Logitech M525] on usb-0000:00:14.0-1:1
Jul  5 02:33:22 Nicu-PC kernel: [111845.478076] input: Logitech K400 as /devices/pci0000:00/0000:00:14.0/usb1/1-1/1-1:1.2/0003:046D:C52B.0009/0003:046D:4024.000B/input/input28
Jul  5 02:33:22 Nicu-PC kernel: [111845.478719] logitech-hidpp-device 0003:046D:4024.000B: input,hidraw8: USB HID v1.11 Keyboard [Logitech K400] on usb-0000:00:14.0-1:2

It has two devices associated with it, the mouse and keyboard listed above. I don't know if they are relevant on Haiku, but I thought it would be best to offer you the full output.

Haiku throws the kernel panic after it reaches the fourth icon on the boot splash (the PC with Haiku's leaf on it).

If I connect the USB Logitech Unifying Receiver after Haiku started up, syslog reports this:

~> tail /var/log/syslog
2018-07-05 02:55:32 KERN: usb hub 17: port 3: new device connected
2018-07-05 02:55:32 KERN: usb ehci -1: fullspeed device connected, giving up port ownership
2018-07-05 02:55:33 KERN: usb hub 7: port 1: new device connected
2018-07-05 02:55:35 KERN: usb error control pipe 45: timeout waiting for queued request to complete
Last message repeated 2 times
2018-07-05 02:55:40 KERN: usb error uhci -1: error while setting device address
2018-07-05 02:55:43 KERN: usb error control pipe 45: timeout waiting for queued request to complete
Last message repeated 2 times
2018-07-05 02:55:47 KERN: usb error uhci -1: 2018-07-05 02:55:47 KERN: error while setting device address
2018-07-05 02:55:47 KERN: usb hub 17: port 3: device removed

If there's anything else I can provide here, I will gladly do so. My Haiku release is hrev52045 gcc2_hyrbid.

Attachments (1)

P_20180705_021458_w1280px.jpg (306.4 KB ) - added by kneekoo 16 months ago.

Download all attachments as: .zip

Change History (2)

by kneekoo, 16 months ago

comment:1 by diver, 16 months ago

Blocked By: 9118 added
Resolution: duplicate
Status: newclosed

Dupe of #9118.

Note: See TracTickets for help on using tickets.