Opened 2 months ago

Closed 2 months ago

#14263 closed bug (duplicate)

regression: bcm440x not working anymore

Reported by: taos Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Drivers/Network/broadcom440x Version: R1/Development
Keywords: 6423 Cc: korli
Blocked By: Blocking: #14262
Has a Patch: no Platform: All

Description

My ethernet adapter (/dev/net/broadcom440x/0) stopped being recognized (= not seen in network preflet or with ifconfig) during the last 13 months.

With hrev51149 gcc2hybrid it is still recognized:

  • from syslog (complete syslog for hrev51149 attached):
    KERN: [broadcom440x] (bfe) bus_alloc_resource(3, [16], 0x0, 0xffffffff, 0x1,0x2)
    KERN: add_memory_type_range(4678, 0xd0204000, 0x20000, 0)
    KERN: set MTRRs to:
    KERN:   mtrr:  0: base:    0xc0000, size:    0x40000, type: 0
    KERN:   mtrr:  1: base: 0x4ff70000, size:    0x10000, type: 0
    KERN:   mtrr:  2: base: 0xd0000000, size:  0x8000000, type: 0
    KERN:   mtrr:  3: base: 0x80000000, size: 0x80000000, type: 1
    KERN: [broadcom440x] (bfe) bus_alloc_resource(1, [0], 0x0, 0xffffffff, 0x1,0x6)
    KERN: if_initname(0x829e4000, bfe, 20)
    KERN: [broadcom440x] broadcom440x: /dev/net/broadcom440x/0
    KERN: [broadcom440x] () Found MII: bmtphy
    KERN: [broadcom440x] () OUI 0x000818, model 0x0036, rev. 0
    KERN: [broadcom440x] ()  ifmedia_add: Adding Entry...
    KERN:   Type: Ethernet
    KERN:   SubType: none
    KERN: noneifmedia_add: Adding Entry...
    KERN:   Type: Ethernet
    KERN:   SubType: 10baseT/UTP
    KERN: , 10baseTifmedia_add: Adding Entry...
    KERN:   Type: Ethernet
    KERN:   SubType: 10baseT/UTP
    KERN:   Shared Option[0]: full-duplex
    KERN: , 10baseT-FDXifmedia_add: Adding Entry...
    KERN:   Type: Ethernet
    KERN:   SubType: 100baseTX
    KERN: , 100baseTXifmedia_add: Adding Entry...
    KERN:   Type: Ethernet
    KERN:   SubType: 100baseTX
    KERN:   Shared Option[0]: full-duplex
    KERN: , 100baseTX-FDXifmedia_add: Adding Entry...
    KERN:   Type: Ethernet
    KERN:   SubType: autoselect
    KERN: , auto
    KERN: ifmedia_set: target   Type: Ethernet
    KERN:   SubType: autoselect
    KERN: ifmedia_set: setting to   Type: Ethernet
    KERN:   SubType: autoselect
    KERN: broadcom440x: init_driver(0xcde90558) at 8
    KERN: loaded driver /boot/system/add-ons/kernel/drivers/dev/net/broadcom440x
    KERN: [net/broadcom440x/0] compat_open(0x2)
    KERN: ifmedia_ioctl: switching bfe to   Type: Ethernet
    KERN:   SubType: autoselect
    KERN: /dev/net/broadcom440x/0: media change, media 0x22 quality 1000 speed 10000000
    ...
    KERN: /dev/net/broadcom440x/0: media change, media 0x900026 quality 1000 speed 10000000
    KERN: register_domain(4, link)
    DAEMON 'DHCP': /dev/net/broadcom440x/0: Send DHCP_DISCOVER to 255.255.255.255:67
    DAEMON 'DHCP': /dev/net/broadcom440x/0: Received DHCP_OFFER from 192.168.178.1
    DAEMON 'DHCP':   your_address: 192.168.178.22
    DAEMON 'DHCP':   server: 192.168.178.1
    DAEMON 'DHCP':   lease time: 864000 seconds
    DAEMON 'DHCP':   renewal time: 432000 seconds
    DAEMON 'DHCP':   rebinding time: 756000 seconds
    DAEMON 'DHCP':   subnet: 255.255.255.0
    DAEMON 'DHCP':   gateway: 192.168.178.1
    DAEMON 'DHCP':   nameserver[0]: 192.168.178.1
    DAEMON 'DHCP':   domain name: "XXX.xxx"
    DAEMON 'DHCP':   broadcast: 192.168.178.255
    DAEMON 'DHCP': /dev/net/broadcom440x/0: Send DHCP_REQUEST for 192.168.178.22 to 255.255.255.255:67
    DAEMON 'DHCP': /dev/net/broadcom440x/0: Received DHCP_ACK from 192.168.178.1
    DAEMON 'DHCP':   server: 192.168.178.1
    DAEMON 'DHCP':   lease time: 864000 seconds
    DAEMON 'DHCP':   renewal time: 432000 seconds
    DAEMON 'DHCP':   rebinding time: 756000 seconds
    DAEMON 'DHCP':   subnet: 255.255.255.0
    DAEMON 'DHCP':   gateway: 192.168.178.1
    DAEMON 'DHCP':   nameserver[0]: 192.168.178.1
    DAEMON 'DHCP':   domain name: "XXX.xxx"
    DAEMON 'DHCP':   broadcast: 192.168.178.255
    DAEMON 'DHCP': /dev/net/broadcom440x/0: DHCP status = No error
    
  • from listdev:
    device Network controller (Ethernet controller) [2|0|0]
      vendor 14e4: Broadcom Limited
      device 4401: BCM4401 100Base-T
    
  • from listimage | grep drivers:
     1389 0xcde78000 0xcde90000     0          0 /boot/system/add-ons/kernel/drivers/dev/net/broadcom440x
    
  • from ifconfig:
    /dev/net/broadcom440x/0
    	Hardware type: Ethernet, Address: 00:c0:9f:25:22:4b
    	Media type: 100 MBit, 100BASE-TX
    	inet addr: 192.168.178.22, Bcast: 192.168.178.255, Mask: 255.255.255.0
    	MTU: 1500, Metric: 0, up broadcast link auto-configured
    	Receive: 2808 packets, 0 errors, 3462938 bytes, 0 mcasts, 0 dropped
    	Transmit: 1932 packets, 0 errors, 143272 bytes, 0 mcasts, 0 dropped
    	Collisions: 0
    

In contrast, with hrev52029 all I get is:

  • from syslog (complete syslog attached for hrev52029):
    KERN: [broadcom440x] (bfe) bus_alloc_resource(3, [16], 0x0, 0xffffffff, 0x1,0x2)
    KERN: add_memory_type_range(4317, 0xd0204000, 0x20000, 0)
    KERN: set MTRRs to:
    KERN:   mtrr:  0: base:    0xc0000, size:    0x40000, type: 0
    ...
    KERN:   mtrr:  1: base: 0x4ff70000, size:    0x10000, type: 0
    KERN:   mtrr:  2: base: 0xd0000000, size:  0x8000000, type: 0
    ...
    KERN:   mtrr:  3: base: 0x80000000, size: 0x80000000, type: 1
    KERN: [broadcom440x] (bfe) bus_alloc_resource(1, [0], 0x0, 0xffffffff, 0x1,0x6)
    ...
    KERN: if_initname(0x829bec00, bfe, 20)
    KERN: [broadcom440x] broadcom440x: /dev/netKERN: /broadcom440x/0
    ...
    KERN: [broadcom440x] () Found MII: bmtphy
    ...
    KERN: [broadcom440x] () OUI 0x000818, model 0x0036, rev. 0
    KERN: [broadcom440x] ()  package_daemon [49156173:   352] active package: "libmikmod_x86-3.3.11.1-1-x86_gcc2.hpkg"
    KERN: ifmedia_add: Adding Entry...
    KERN:   Type: Ethernet
    ...
    KERN:   SubType: none
    KERN: noneifmedia_add: Adding Entry...
    ...
    KERN:   Type: Ethernet
    KERN:   SubType: 10baseT/UTP
    ...
    KERN: , 10baseTifmedia_add: Adding Entry...
    ...
    KERN:   Type: Ethernet
    KERN:   SubType: 10baseT/UTP
    ...
    KERN:   Shared Option[0]: full-duplex
    KERN: , 10baseT-FDXpackage_daemon [49260748:   352] active package: "freetype_x86-2.9-1-x86_gcc2.hpkg"
    KERN: ifmedia_add: Adding Entry...
    KERN:   Type: Ethernet
    ...
    KERN:   SubType: 100baseTX
    KERN: , 100baseTXifmedia_add: Adding Entry...
    ...
    KERN:   Type: Ethernet
    KERN:   SubType: 100baseTX
    ...
    KERN:   Shared Option[0]: full-duplex
    KERN: , 100baseTX-FDXpackage_daemon [49319538:   352] active package: "libsdl_x86_devel-1.2.15-13-x86_gcc2.hpkg"
    KERN: ifmedia_add: Adding Entry...
    KERN:   Type: Ethernet
    ...
    KERN:   SubType: autoselect
    KERN: , auto
    KERN: ifmedia_set: target package_daemon [49349192:   352] active package: "libwebp5_x86-0.4.4-2-x86_gcc2.hpkg"
    KERN:   Type: Ethernet
    KERN:   SubType: autoselect
    ...
    KERN: ifmedia_set: setting to   Type: Ethernet
    ...
    KERN:   SubType: autoselect
    KERN: if_attach 0xcf1256d4
    ...
    KERN: broadcom440x: init_driver(0x806b3078) at 8
    KERN: loaded driver /boot/system/add-ons/kernel/drivers/dev/net/broadcom440x
    
  • from listdev:
    device Network controller (Ethernet controller) [2|0|0]
      vendor 14e4: Broadcom Limited
      device 4401: BCM4401 100Base-T
    
  • from listimage | grep drivers :
     1253 0x80699000 0x806b2000     0          0 /boot/system/add-ons/kernel/drivers/dev/net/broadcom440x
    
  • from ifconfig:
       
    

Attachments (2)

syslog_hrev52029 (159.8 KB) - added by taos 2 months ago.
Syslog for hrev52029.
syslog_hrev51149 (640.9 KB) - added by taos 2 months ago.
Syslog for hrev51149.

Download all attachments as: .zip

Change History (7)

Changed 2 months ago by taos

Attachment: syslog_hrev52029 added

Syslog for hrev52029.

Changed 2 months ago by taos

Attachment: syslog_hrev51149 added

Syslog for hrev51149.

comment:1 Changed 2 months ago by diver

Blocking: 14262 added

comment:2 Changed 2 months ago by waddlesplash

Cc: korli added

The changes from FreeBSD 11.1 (hrev51928) are extremely minimal; so it's probably not that. It appears the problem is that compat_open is never being called; can you double-check /dev/net/broadcom440x/ and make sure there's a 0 device there?

It seems very strange that the device would get published but then the rest of the stack would do nothing with it.

comment:3 Changed 2 months ago by waddlesplash

Hmm, actually I wonder if this is another manifestation of #6423? If the interface is in /dev, you can try running the ifconfig command mentioned in that ticket.

comment:4 Changed 2 months ago by taos

Yep, looks like #6423. Happened probably when I tried to (unsuccessfully) get the iprowifi2100 to work with my router.

comment:5 Changed 2 months ago by waddlesplash

Keywords: 6423 added
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.