Opened 2 months ago

Last modified 2 months ago

#14266 new bug

iprowifi4965 : wireless network disappears before login

Reported by: ttcoder Owned by: waddlesplash
Priority: normal Milestone: Unscheduled
Component: Drivers/Network/iprowifi4965 Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

On boot-up complete the network is listed at first; I select it and enter the password when prompted a few seconds later. But then the password dialog re-appears.. Probably because by then the network has "disappeared":

IOW, my wifi router's network gets listed at first, then disappears in a few seconds, never to re-appear for that session.

This is with today's nightly. Could also try an "ancient" nightly if that'd help.

Attachments (1)

syslog_t410 (22.8 KB) - added by ttcoder 2 months ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 2 months ago by ttcoder

This is on the family lenovo T410. Probably my last wifi ticket as I've made the rounds of the wifi-capable 'puters here :-)

More:

Haiku shredder 1 hrev52094 Jul 11 2018 22:43:35 BePC x86 Haiku

device Network controller [2|80|0]
  vendor 8086: Intel Corporation
  device 4239: Centrino Advanced-N 6200

~/> ls /system/settings/network/
hostname  hosts  resolv.conf  services

PS - anyone else seeing media_addon_server crashing on boot? I'll file a ticket if this persists; or maybe this is just specific to booting from a (slow) USB thumbdrive

EDIT: noting before I forget, should /really/ look for firmwares on intellinuxwireless.org and try again, as per #14260

Last edited 2 months ago by ttcoder (previous) (diff)

Changed 2 months ago by ttcoder

Attachment: syslog_t410 added

comment:2 Changed 2 months ago by waddlesplash

Yes, a newer firmware might be useful, so please do try that. But it looks like this isn't a driver problem; it seems that the "station deauth" because "sending STA is leaving/has left IBSS or ESS" may be related to your access point doing channel-hopping: https://supportforums.cisco.com/t5/small-business-wireless/wap321-sta-is-leaving-ibss-or-ess/td-p/2349232

If this is indeed the case then this isn't a driver bug, and is instead a router bug or just traffic congestion causing the router to behave strangely, and would explain #14260 and #14258 as well.

More information could be had by adding a #define IWN_DEBUG just above here and then editing line 54 of that same file to comment out the if-test (i.e. leave printf, make it occur unconditionally).

comment:3 Changed 2 months ago by waddlesplash

Indeed, the same "station deauth" message is in #14260:

KERN: [net/iprowifi3945/0] [d0:ae:ec:3e:a9:b0] station deauth via MLME (reason: 3 (sending STA is leaving/has left IBSS or ESS))

So unless net80211 or the driver are incorrectly reporting MLME states (unlikely, more would be broken) it seems your access point is the problem here.

comment:4 Changed 2 months ago by ttcoder

Re. firmware,

  • for a start, I tried the first of the six or so files available on that site, behaved the same though.
  • ~EDIT: note to self: if that becomes relevant, gotta bring up the fact that the behavior is the same also if the firmware is black-listed and no replacement is provided; that prompted me to look at the mapping but it looks ok.. ~

Re. the Cisco support hints,

based on ""It looks like your WAP may be set to auto mode for the channel. You will get disconnects like that when the WAP automatically changes  channels"" I went to my router (which is a france telecom "LiveBox") config > Wifi > Advanced. There is a channel setting there indeed. It was set to "Auto". I've set it to a fixed channel among the 14 proposed. Will report again (probably tomorrow) about any change.

Last edited 2 months ago by ttcoder (previous) (diff)

comment:5 Changed 2 months ago by ttcoder

No change with channel-hopping disabled (router hardcoded to channel 6): the wifi network remains listed as long as I don't connect; then it disappears when I try to connect to it (very Heisenberg'ish of him :-), together with that strange media_addon_server crash too.

Anyway no big deal to me if I don't get wifi on that particular laptop; might revisit the above to-dos later for the sake of helping with haiku's compatibility though.

comment:6 Changed 2 months ago by waddlesplash

If the firmware is blacklisted and no replacement is provided, then are you sure it's loading the firmware you believe it is? Most chipsets should just not work at all without firmware (from a *cold* boot anyway.)

comment:7 in reply to:  6 Changed 2 months ago by ttcoder

Tried again from cold boot twice, and indeed, nothing gets listed in that case. So it was a case of having booted into a firmware-enabled install, then doing a warm reboot to a firmware-less one. Gotta keep that in mind in the future. So back on track with experimenting alternative firmwares. (and I might do a cold boot each time I try a new version to be sure of the result, this preserve-state-across-warm-boots business is kinda unnerving..!)

Note: See TracTickets for help on using tickets.