Opened 10 months ago

Last modified 10 months ago

#14268 new bug

AR2413/14 Not Detected

Reported by: I_Am_Kor Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: System Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I am using hrev52093 and my Atheros AR2413/14 is not detected. Its not even listed in /dev/net.

I have attached listdev and a capture of the PCIID.

Let me know if I can do anything else.

Attachments (3)

listdev.txt (3.4 KB) - added by I_Am_Kor 10 months ago.
pcidev.jpeg (676.7 KB) - added by I_Am_Kor 10 months ago.
syslog (364.1 KB) - added by I_Am_Kor 10 months ago.

Download all attachments as: .zip

Change History (10)

Changed 10 months ago by I_Am_Kor

Attachment: listdev.txt added

Changed 10 months ago by I_Am_Kor

Attachment: pcidev.jpeg added

comment:1 Changed 10 months ago by waddlesplash

Please attach a syslog, and please try a build of FreeBSD if you can and see if it works on that.

comment:2 Changed 10 months ago by waddlesplash

Component: Drivers/NetworkDrivers/Network/atheroswifi
Owner: changed from nobody to waddlesplash

Changed 10 months ago by I_Am_Kor

Attachment: syslog added

comment:3 Changed 10 months ago by I_Am_Kor

Works fine on FreeBSD 11.2, I just tested it.

comment:4 Changed 10 months ago by diver

[atheroswifi] (ath_pci) bus_alloc_resource(3, [16], 0x0, 0xffffffff, 0x1,0x2)
[atheroswifi] (ath_pci) bus_alloc_resource(1, [0], 0x0, 0xffffffff, 0x1,0x6)
[atheroswifi] (ath_pci) unable to attach hardware; HAL status 3

Looks like your Atheros device is behind a PCI bridge: http://madwifi-project.org/wiki/UserDocs/Troubleshooting#WhenIloadtheath_pcimoduleIgetunabletoattachhardware:HardwaredidntrespondasexpectedHALstatus3

comment:5 Changed 10 months ago by I_Am_Kor

Okay, so do I need to do anything?

comment:6 Changed 10 months ago by waddlesplash

Component: Drivers/Network/atheroswifiSystem
Owner: changed from waddlesplash to nobody

I don't know if our PCI bus even supports that property correctly; at any rate, it's not a problem in the driver. Reassigning to PCI component so someone else can take a look at it.

comment:7 Changed 10 months ago by I_Am_Kor

So swapping out wifi cards won't help?

Note: See TracTickets for help on using tickets.