Opened 2 months ago

Closed 2 months ago

#14333 closed bug (fixed)

intel_extreme: attempting to clone non-user-cloneable kernel area!

Reported by: BlueSky Owned by: waddlesplash
Priority: normal Milestone: R1/beta1
Component: Drivers/Graphics/intel_extreme Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #14334, #14335
Has a Patch: no Platform: x86-64

Description

Haiku x86_64 KDL's at boot with "PANIC: attempting to clone non-user-cloneable kernel area!". Happens with the 2 latest hrevs. Last working hrev is 52183. The bug is reproducable. Cell phone photo of the KDL attached. I can provide more info on advice.

Attachments (3)

KDL.jpg (155.9 KB) - added by BlueSky 2 months ago.
DSCN0402.JPG (4.1 MB) - added by bbjimmy 2 months ago.
KLD hrev52197
syslog (499.6 KB) - added by bbjimmy 2 months ago.
log from the latest boot attempt

Change History (18)

Changed 2 months ago by BlueSky

Attachment: KDL.jpg added

comment:1 Changed 2 months ago by pulkomandy

Component: System/KernelDrivers/Graphics/intel_extreme
Owner: changed from nobody to waddlesplash
Status: newassigned

Most likely because of https://git.haiku-os.org/haiku/commit/?id=023a547dc6981f10bb8437cfba7fcaa3fe3b0d01

I would suggest reverting this change for the beta, it is too dangerous to do this close to a release. We can do it after the beta is out.

comment:2 Changed 2 months ago by waddlesplash

I'd prefer to try and fix these bugs. If need be, we can revert in the beta branch.

comment:3 Changed 2 months ago by waddlesplash

Blocking: 14334 added

comment:4 Changed 2 months ago by waddlesplash

Blocking: 14335 added

comment:5 Changed 2 months ago by waddlesplash

Summary: KDL at bootintel_extreme: attempting to clone non-user-cloneable kernel area!

comment:6 Changed 2 months ago by bbjimmy

This issue should either be be a Beta blocker, or the offending change should be reverted.

comment:7 Changed 2 months ago by waddlesplash

Milestone: UnscheduledR1/beta1

It's a one or two line fix, so unless there are more bugs like it in other drivers, it won't delay the beta at all. I'll make the fix later today.

comment:8 Changed 2 months ago by waddlesplash

The problem is here: http://xref.plausible.coop/source/xref/haiku/src/add-ons/kernel/drivers/graphics/intel_extreme/intel_extreme.cpp#357

In addition to B_KERNEL_READ_AREA | B_KERNEL_WRITE_AREA, there should also be | B_USER_CLONEABLE_AREA.

comment:9 Changed 2 months ago by pulkomandy

Done in hrev52196.

comment:10 Changed 2 months ago by waddlesplash

Resolution: fixed
Status: assignedclosed

bbjimmy reports this as fixed, but he says there is a different panic relating to acpi_task.

comment:11 Changed 2 months ago by BlueSky

On my system hrev52197 is booting properly.

Changed 2 months ago by bbjimmy

Attachment: DSCN0402.JPG added

KLD hrev52197

comment:12 Changed 2 months ago by bbjimmy

Resolution: fixed
Status: closedreopened

comment:13 Changed 2 months ago by waddlesplash

This doesn't seem to make a lot of sense. There are only 2 areas cloned in that function, they are not cloned conditionally, and if it works on one intel_extreme system (as BlueSky says it does) it should work everywhere. Are you sure you are really on 52197?

Changed 2 months ago by bbjimmy

Attachment: syslog added

log from the latest boot attempt

comment:14 Changed 2 months ago by bbjimmy

I am as sure as I can be, I just attatched the syslog from the boot attempt.

comment:15 Changed 2 months ago by waddlesplash

Resolution: fixed
Status: reopenedclosed
KERN: loaded driver /boot/home/config/non-packaged/add-ons/kernel/drivers/dev/graphics/intel_extreme

It seems you have an old intel_extreme driver in non-packaged.

Note: See TracTickets for help on using tickets.