Opened 14 months ago

Last modified 9 months ago

#14344 new bug

Network speed extremely slow

Reported by: roiredxsoto Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Network & Internet Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Good day everyone,

I'm just getting internet access speeds too slow on a 100 Mbps connection. Webpages take up to 50 seconds to load wether with Web+ or QupZilla.

Haiku Rolling Version:

~> uname -a
Haiku shredder 1 hrev52203 Aug  9 2018 21:12:44 x86_64 x86_64 Haiku

Ethernet chip:

~> listdev | grep "net"
device Network controller (Ethernet controller) [2|0|0]
  device 8168: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller

Wired network only. No wireless available. DCHP does not connect at all. It stucks at "configuring"

Attachments (5)

20180810-2003-syslog (177.9 KB ) - added by roiredxsoto 14 months ago.
Syslog of fresh start
20180810-2001-syslog.old (512.1 KB ) - added by roiredxsoto 14 months ago.
Previous Syslog
20180817-WebPositive-1590-debug-17-08-2018-19-58-08.report (36.6 KB ) - added by roiredxsoto 14 months ago.
Web+ Debug Report
NetworkSpeed.png (2.3 MB ) - added by roiredxsoto 13 months ago.
Network speed comparison. Same Hardware, Xubuntu on top, Haiku on bottom. Net speed is up to 5 times faster on same hardware on Xubuntu
HaikuVBoxNetwork.png (20.3 KB ) - added by roiredxsoto 13 months ago.
Haiku on VBox. Network (shared) shows it is 4 times faster than on real hardware

Change History (12)

by roiredxsoto, 14 months ago

Attachment: 20180810-2003-syslog added

Syslog of fresh start

by roiredxsoto, 14 months ago

Attachment: 20180810-2001-syslog.old added

Previous Syslog

comment:1 by roiredxsoto, 14 months ago

Ping times match those of Linux on the same Bare Metal. 53-55 ms to reach Haiku-os.org. It also happens in the Virtual Machine. Pings are ok, web browsing is slow and takes ages to load pages, and even HaikuDepot takes time to load and install apps. Only software updater "seems" to be fine.

by roiredxsoto, 14 months ago

Web+ Debug Report

comment:2 by diver, 14 months ago

Please open a new issue for Web+ crash.

by roiredxsoto, 13 months ago

Attachment: NetworkSpeed.png added

Network speed comparison. Same Hardware, Xubuntu on top, Haiku on bottom. Net speed is up to 5 times faster on same hardware on Xubuntu

by roiredxsoto, 13 months ago

Attachment: HaikuVBoxNetwork.png added

Haiku on VBox. Network (shared) shows it is 4 times faster than on real hardware

comment:3 by roiredxsoto, 13 months ago

Good day everyone,

Inside VBox, with network set to "Intel PRO Desktop"; the results are:

~> uname -a
Haiku shredder 1 hrev52316 Sep  7 2018 20:25:33 x86_64 x86_64 Haiku

Network:

~> listdev | grep "net"
device Network controller (Ethernet controller) [2|0|0]
  device 100e: 82540EM Gigabit Ethernet Controller

Inside VBox network is working under DHCP address assingment. So basically, Haiku uses the routing table set inside the Host (Xubuntu).

When runing Haiku on BM (same hardware as Xubuntu and identified in the previous post) the routing table does not hold more than 3 entries, which I presume is the cause for the slow down. Also DHCP does not work at all on BM in Haiku (it works on Xubuntu).

Version 0, edited 13 months ago by roiredxsoto (next)

comment:4 by waddlesplash, 13 months ago

DHCP problems are a known issue. If it works in VirtualBox, then it may just be that your network controller driver from FreeBSD is slow.

in reply to:  4 comment:5 by roiredxsoto, 13 months ago

Replying to waddlesplash:

DHCP problems are a known issue. If it works in VirtualBox, then it may just be that your network controller driver from FreeBSD is slow.

Thanks waddlesplash. I'll keep checking to identify better the source of the problem. Regards, RR

comment:6 by waddlesplash, 9 months ago

Please retest under a recent nightly.

comment:7 by roiredxsoto, 9 months ago

Good day @waddlesplash, I will do. As soon as I fix the dual boot, because I broke it and now can't start Haiku. This weekend will fix it and retest with a recent update. Thanks for your efforts! Regards, RR

Note: See TracTickets for help on using tickets.