Opened 12 years ago

Closed 12 years ago

#1443 closed bug (fixed)

Drawing of selection in Tracker list view mode is broken

Reported by: jonas.kirilla Owned by: stippi
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Open /boot or /boot/home in Tracker list view mode and try selecting a file using the mouse. You won't see any visual update of the selection, no drawing, until some other state changes, like if you use the arrow keys or if the focus changes.

Maybe hrev22040 caused this: http://svn.berlios.de/viewcvs/haiku/haiku/trunk/src/kits/tracker/?sortby=date#dirlist

Attachments (8)

Haiku_screen1.png (73.3 KB ) - added by jonas.kirilla 12 years ago.
Haiku_screen2.png (72.9 KB ) - added by jonas.kirilla 12 years ago.
Haiku_screen3.png (32.0 KB ) - added by jonas.kirilla 12 years ago.
Haiku_screen4.png (33.1 KB ) - added by jonas.kirilla 12 years ago.
R5_filename_overlay.png (3.5 KB ) - added by jonas.kirilla 12 years ago.
R5_icon_view.png (53.1 KB ) - added by jonas.kirilla 12 years ago.
R5_icon_view_2.png (51.8 KB ) - added by jonas.kirilla 12 years ago.
R5_query_list_view.png (10.7 KB ) - added by jonas.kirilla 12 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 by stippi, 12 years ago

Owner: changed from axeld to stippi
Status: newassigned

Yes, it was certainly caused by my patch. I always select files by using the drag box, that's why I actually never saw that problem before commiting my patch... sorry.

by jonas.kirilla, 12 years ago

Attachment: Haiku_screen1.png added

by jonas.kirilla, 12 years ago

Attachment: Haiku_screen2.png added

by jonas.kirilla, 12 years ago

Attachment: Haiku_screen3.png added

by jonas.kirilla, 12 years ago

Attachment: Haiku_screen4.png added

by jonas.kirilla, 12 years ago

Attachment: R5_filename_overlay.png added

by jonas.kirilla, 12 years ago

Attachment: R5_icon_view.png added

by jonas.kirilla, 12 years ago

Attachment: R5_icon_view_2.png added

by jonas.kirilla, 12 years ago

Attachment: R5_query_list_view.png added

comment:2 by jonas.kirilla, 12 years ago

Hopefully relevant screenshots uploaded.

(Screenshots Haiku_screen2.png, Haiku_screen4.png and R5_icon_view_2.png don't show any problems, AFAIK. The problem only occurs when a Tracker window has focus, as these shots of unfocused windows illustrates.)

This is with hrev22149 of Tracker on Haiku and on R5.

comment:3 by stippi, 12 years ago

Resolution: fixed
Status: assignedclosed

Fixed in hrev22190. Though not satisfactorily, since selecting stuff in Tracker (list mode) now flickers. The code was calculating invalidation rects wrongly (icon mode <-> list mode) and it invalidates all over the place with no clear code path. The flickering problem would probably have shown itself before my initial patch for text outlines, if BPoseView would have calculated the dirty rects correctly.

Note: See TracTickets for help on using tickets.