Opened 23 months ago

Closed 7 weeks ago

Last modified 6 weeks ago

#14437 closed bug (fixed)

Cannot open specific SVG icons

Reported by: konrad Owned by: stippi
Priority: normal Milestone: R1/beta2
Component: Applications/Icon-O-Matic Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description

Icon-o-matic cannot open SVG icons from https://octicons.github.com.

Steps to reproduce:

  1. Download icon set from here: https://octicons.github.com
  2. Try to open them in Icon-o-matic.

Maybe Icon-o-matic should show some type of error message for an unsucceful import?

Change History (4)

comment:1 by pulkomandy, 2 months ago

The problem is that Icon O Matic decides this is not an SVG file because it lacks the "<?xml" header.

I made a fix here: https://review.haiku-os.org/c/haiku/+/2662

However these icons still don't render properly after that.

comment:2 by waddlesplash, 7 weeks ago

Resolution: fixed
Status: newclosed

Fix merged in hrev54246.

comment:3 by waddlesplash, 7 weeks ago

Keywords: Does not support some svg-icons removed

comment:4 by nielx, 6 weeks ago

Milestone: UnscheduledR1/beta2

Assign tickets with status=closed and resolution=fixed within the R1/beta2 development window to the R1/beta2 Milestone

Note: See TracTickets for help on using tickets.