Opened 3 years ago

Closed 2 years ago

Last modified 16 months ago

#14467 closed bug (fixed)

[MidiPlayer] crashes in MidiPlayerWindow::StopHook()

Reported by: diver Owned by: nobody
Priority: normal Milestone: R1/beta2
Component: Applications/MidiPlayer Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description

hrev52316 x86_64.

MidiPlayer crashes after clicking stop button.

Attachments (1)

MidiPlayer-29561-debug-10-09-2018-13-32-39.report (14.6 KB ) - added by diver 3 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 by diver, 3 years ago

Component: - GeneralApplications/MidiPlayer

comment:2 by waddlesplash, 3 years ago

Can't reproduce this. Does it happen on all MIDI files, or just some?

comment:3 by diver, 3 years ago

Apparently it still happens https://youtu.be/DCHZboNN12U?t=1062

comment:4 by diver, 3 years ago

https://upload.wikimedia.org/wikipedia/commons/5/55/MIDI_sample.mid

MidiPlayer crashes differentally depending on weather timgmsoundfont is installed or not.

comment:5 by diver, 2 years ago

Resolution: fixed
Status: newclosed

Can't reproduce after hrev52933. Closing as fixed.

comment:6 by Kitsune64, 19 months ago

I got an error with this App every time I close this app or stoping playing a MIDI file.

comment:7 by humdinger, 19 months ago

Is the debug report similar to the one in this ticket? If not, please open a new ticket and attach your report there.

comment:8 by nielx, 16 months ago

Milestone: UnscheduledR1/beta2

Assign tickets with status=closed and resolution=fixed within the R1/beta2 development window to the R1/beta2 Milestone

Note: See TracTickets for help on using tickets.