Opened 2 months ago

Last modified 2 months ago

#14474 new bug

PANIC: get_boot_partitions_failed!

Reported by: xray72 Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Drivers/Disk Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I have tried to install Haiku 64 with anyboot (hrev52325-x86_64-anyboot) ISO burned to a USB (using Etcher).

I have a kernel panic at boot loading step:

PANIC: get_boot_partitions_failed!
Welcome to Kernel Debugging Land...
Thread 26 "main2" running on CPU 10
stack trace for thread 26 "main2"
  kernel stack: 0xffffffff81286000 to 0xffffffff8128b000

I tried to unplug as much USB device as I could, all harddrive (I've got 4 in this high tower system, plus a CDROM) and this does not change anything. If I try to activate any boot option in Haiku boot loader then I cannot select the boot device anymore (set to none) and I cannot boot. Changing BIOS options on USB did not change anything.

Attachments (3)

IMAG0334.jpg (2.7 MB) - added by xray72 2 months ago.
PANIC: get_boot_partitions failed!
SYSLOG00.TXT (62.0 KB) - added by xray72 2 months ago.
syslog
SYSLOG01.TXT (11.9 KB) - added by xray72 2 months ago.
Syslog #2

Change History (11)

Changed 2 months ago by xray72

Attachment: IMAG0334.jpg added

PANIC: get_boot_partitions failed!

comment:1 Changed 2 months ago by xray72

I have tried to boot from the CDROM and I get exactly the same message.

comment:2 Changed 2 months ago by waddlesplash

That message is useless without a syslog accompanying it, as it just means the bootloader couldn't find any partitions to boot from.

Try reading the Bootloader documentation as to how to extract syslogs: https://www.haiku-os.org/docs/userguide/en/bootloader.html -- or if all that fails, you can type syslog at that kernel panic prompt and take pictures of the output one screen at a time.

Most likely it's due to some problem in the XHCI (USB3) driver though, which would make this a duplicate of some of those tickets. IIRC kallisti5 said that he saw this on an XHCI system he has. Although, if the same thing happens when booting from CD, perhaps your image burner is at fault...?

Changed 2 months ago by xray72

Attachment: SYSLOG00.TXT added

syslog

comment:3 Changed 2 months ago by xray72

Thanks for the tip, and sorry, I read that too quickly. You'll find the syslog attached (but only with USB boot because when I boot from CDROM my (USB) Keyboard is not working at all.

comment:4 Changed 2 months ago by waddlesplash

Looks like the memory got corrupted and the file ends before the actual output does, which isn't very useful...

Changed 2 months ago by xray72

Attachment: SYSLOG01.TXT added

Syslog #2

comment:5 Changed 2 months ago by xray72

Doing my best, this one looks better.

comment:6 Changed 2 months ago by xray72

Ok, I managed to boot. I removed all drives (I had forgotten one which is hidden) and I changed SATA settings from RAID to AHCI in the BIOS.

comment:7 Changed 2 months ago by xray72

I plugged back one drive and it still boots so it seems it was this SATA RAID setting (which does not disturb neither Windows 10 nor Ubuntu Linux 16.04).

comment:8 Changed 2 months ago by diver

Component: - GeneralDrivers/Disk
Note: See TracTickets for help on using tickets.