Opened 5 months ago

Closed 3 weeks ago

#14505 closed bug (fixed)

General network problems on Thinkpad T420

Reported by: smashIt Owned by: waddlesplash
Priority: high Milestone: Unscheduled
Component: Drivers/Network/iprowifi4965 Version: R1/Development
Keywords: Thinkpad T420 iprowifi4965 Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by diver)

I've had these problems since I installed Haiku on my Thinkpad T420. Currently hrev52355 is installed.

First off the wired network device (intel 82579LM according to devices) doesn't work at all.

The WLAN device (intel centrino wireless N 1000 according to devices) has a bunch of problems:

  • selecting a network from by right clicking the icon in the deskbar will prompt you to enter the network password. After entering it an clicking OK it asks you again, and again, and again...
  • clicking Cancel sometimes works, sometimes not.
  • selecting the network from the network panel most of the times connects you to the network.
  • when finally connected it won't get an IP-address through DHCP.
  • switching to Static and back to DHCP will result in an IP-address.
  • when you have the popup for the password on screen and disable the device, clicking OK in the password-window will crash it.
  • when the network-panel locks up (happened several times to me) you can kill the network server, but killing wpa_supplicant will land you in KDL.

Under windows everything works as it should, so I don't think it's a hardware-defect.

Change History (4)

comment:1 Changed 5 months ago by diver

Component: Network & Internet/WirelessDrivers/Network/iprowifi4965
Description: modified (diff)
Owner: changed from mmlr to waddlesplash
Platform: x86All

Please file a separate ticket about wired NIC and attach syslog to both tickets.

comment:2 Changed 5 months ago by diver

comment:3 Changed 6 weeks ago by waddlesplash

Please retest after hrev52730.

comment:4 Changed 3 weeks ago by waddlesplash

Resolution: fixed
Status: newclosed

All similar iprowifi4965 tickets closed as fixed after latest upgrade, and no reply on this one in a while, so assuming fixed.

Note: See TracTickets for help on using tickets.