Opened 13 months ago

Closed 12 months ago

Last modified 8 days ago

#14516 closed enhancement (fixed)

Intel(R) I211 Gigabit does't work

Reported by: pragmavalue Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Drivers/Network/ipro1000 Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by diver)

hrev52359.

My network card does't work with Haiku.

Attachments (7)

syslog (228.7 KB ) - added by pragmavalue 13 months ago.
IMG_20190430_095633.jpg (221.6 KB ) - added by pragmavalue 6 months ago.
IMG_20190430_095633.2.jpg (221.6 KB ) - added by pragmavalue 6 months ago.
syslog_hrev53176_UEFInetwork.txt (498.3 KB ) - added by taos 4 months ago.
syslog from hrev53176 with "Enable UEFI Network Stack" activated in UEFI BIOS
syslog_hrev53176_UEFInetwork_igb.txt (7.6 KB ) - added by taos 4 months ago.
syslog excerpt relevant to igb from hrev53176 with "Enable UEFI Network Stack"
syslog_hrev53176_noUEFInetwork_igb.txt (31.1 KB ) - added by taos 4 months ago.
syslog excerpt relevant to igb from hrev53176 without "Enable UEFI Network Stack"
syslog_hrev53176_noUEFInetwork.txt (502.6 KB ) - added by taos 4 months ago.
syslog from hrev53176 without "Enable UEFI Network Stack" activated in UEFI BIOS

Download all attachments as: .zip

Change History (31)

comment:1 by korli, 13 months ago

Please post a syslog, indicate hrev and architecture. see https://dev.haiku-os.org/wiki/ReportingBugs

by pragmavalue, 13 months ago

Attachment: syslog added

comment:2 by diver, 13 months ago

Component: - GeneralDrivers/Network/ipro1000
Description: modified (diff)
Milestone: R1/beta1Unscheduled
Type: bugenhancement

Does it work in FreeBSD? The attached syslog doesn't contain any information about your NIC. Please attach listdev output.

comment:3 by waddlesplash, 12 months ago

Resolution: fixed
Status: newclosed

Added in hrev52442.

comment:4 by taos, 6 months ago

As you've probably read in #14999, it doesn't work for me with hrev53047 64bit. The Intel I211-AT is recognized as /dev/net/ipro1000/0 but is indefinitely stuck at "configuring" and won't get an IP address per DHCP (manually assigning an IP didn't work either).

In case there are different I211 chips around, mine is:

device Network controller (Ethernet controller) [2|0|0]
  vendor 8086: Intel Corporation
  device 1539: I211 Gigabit Network Connection

It works under a FreeBSD 12.0 Release LiveCD (recognized as igb0, DHCP with dhclient).

Last edited 6 months ago by taos (previous) (diff)

by pragmavalue, 6 months ago

Attachment: IMG_20190430_095633.jpg added

by pragmavalue, 6 months ago

Attachment: IMG_20190430_095633.2.jpg added

comment:5 by pragmavalue, 6 months ago

Still don't work. I don't have a FreeBSD and don't check.

comment:6 by waddlesplash, 6 months ago

Did it work on hrev52442 or a hrev near there? I did some major refactors since then which may have broken it.

comment:7 by taos, 6 months ago

Seems I can't check with the Ryzen 5 system from #14999 since it's going straight to KDL with hrev52443 anyboot. Does it make sense to extract the ipro1000 driver from that revision and put it into non-packaged to see what happens?

comment:8 by waddlesplash, 6 months ago

Yes.

comment:9 by bga, 6 months ago

Is it possible this is related to the ipro1000 issues I am seeing? https://dev.haiku-os.org/ticket/15016

comment:10 by waddlesplash, 6 months ago

Possibly, but as this card seems to initialize and then just fails to send traffic, perhaps not.

comment:11 by bga, 6 months ago

I am pretty sure my card initializes to. But then it deadlocks somewhere.

I will do a guarded heap build later today and see if I can find something in any case.

comment:12 by taos, 6 months ago

Put the ipro1000 from hrev52443 in /non-packaged/add-ons/kernel/drivers/bin/, rebooted -> ipro1000 stuck at "Configuring...". Rebooted again with blacklisted ipro1000 -> no ipro1000 found.

comment:13 by waddlesplash, 6 months ago

You have to reboot and then copy the driver into non packaged. You can't copy it in before rebooting with the blacklist.

comment:14 by taos, 6 months ago

Rebooting with blacklisted ipro1000 -> no ipro1000 -> moving ipro1000 out of non-packaged, moving it back -> ipro1000 appears, listimage shows that the driver in non-packaged is used -> ipro1000 stuck at "Configuring ..."

comment:15 by pragmavalue, 6 months ago

Thanks!

in hrev53106 NIC work fine. Please close

comment:16 by taos, 6 months ago

Unfortunately, it still doesn't work for me with hrev53106 64bit anyboot.

Last edited 5 months ago by taos (previous) (diff)

in reply to:  15 comment:17 by taos, 5 months ago

Replying to pragmavalue:

Thanks!

in hrev53106 NIC work fine. Please close

How did you get it to work? Are you using gcc2 hybrid or 64 bit?

comment:18 by taos, 5 months ago

Ah, it works if "Enable UEFI Network Stack" is activated in UEFI BIOS (this option is only there to make it possible to boot from PXE). So far (3 Linux distributions, Windows, FreeBSD), Haiku seems the only operating system in need of this option for a working LAN connection.

comment:19 by waddlesplash, 5 months ago

That probably means that EFI initializes the chip in some way that we are missing. As it works on FreeBSD, this probably implies something at the PCI level or the like, I'd guess.

comment:20 by waddlesplash, 5 months ago

hrev53174 probably fixes that bug.

comment:21 by taos, 5 months ago

Checked with hrev53176 64bit. Unfortunately, without activated "Enable UEFI Network Stack" ipro1000 is still stuck at "Configuring ...".

by taos, 4 months ago

syslog from hrev53176 with "Enable UEFI Network Stack" activated in UEFI BIOS

by taos, 4 months ago

syslog excerpt relevant to igb from hrev53176 with "Enable UEFI Network Stack"

by taos, 4 months ago

syslog excerpt relevant to igb from hrev53176 without "Enable UEFI Network Stack"

by taos, 4 months ago

syslog from hrev53176 without "Enable UEFI Network Stack" activated in UEFI BIOS

comment:22 by taos, 9 days ago

After the update from hrev53379 to hrev53523, I'm greeted with a KDL during boot if ipro1000 is not blacklisted. I'll probably have to open a new ticket for this regression.

comment:23 by waddlesplash, 9 days ago

Yes, please do.

comment:24 by taos, 8 days ago

I opened ticket #15402 for this.

Note: See TracTickets for help on using tickets.