Opened 14 months ago

Closed 14 months ago

Last modified 14 months ago

#14529 closed bug (duplicate)

vm_page_fault KDL when removing files on an ext2 volume

Reported by: v.vill Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: File Systems/ext2 Version: R1/Development
Keywords: Cc:
Blocked By: #14404 Blocking:
Has a Patch: no Platform: All

Description

Greetings,
I've noticed that removing inodes with the ext2 driver tends to trigger a KDL. Here's how I do it:

~> dd if=/dev/zero bs=1024 count=250000 of=/unnamed\ volume/test
250000+0 records in
250000+0 records out
256000000 bytes (256 MB, 244 MiB) copied, 15,3417 s, 16,7 MB/s
~> mv /unnamed\ volume/test ./
~> mv ./test /unnamed\ volume/

The KDL is triggered when I repeat the last two commands a couple of times.

I'm using an ext4 volume formatted with standard options, on hrev52365 x86_64.

Attachments (1)

IMG_20180926_215122.jpg (949.5 KB ) - added by v.vill 14 months ago.
KDL trace

Download all attachments as: .zip

Change History (3)

by v.vill, 14 months ago

Attachment: IMG_20180926_215122.jpg added

KDL trace

comment:1 by waddlesplash, 14 months ago

Blocked By: 14404 added
Resolution: duplicate
Status: newclosed

Ha, it's a duplicate of your own ticket! :-P

comment:2 by v.vill, 14 months ago

Oh, indeed! I didn’t remember reporting this one (I was thinking about #11407 which I reported much earlier on, with regard to NTFS partitions). Nice catch.

Note: See TracTickets for help on using tickets.