Opened 21 months ago

Closed 3 weeks ago

Last modified 2 weeks ago

#14589 closed bug (fixed)

Wacom Graphire4 A6: SMAP violation

Reported by: roiredxsoto Owned by: stippi
Priority: normal Milestone: R1/beta3
Component: Drivers/Input/Wacom Version: R1/Development
Keywords: USB Wacom Digitizer Tablet Cc:
Blocked By: Blocking: #16083
Platform: All

Description

Good day, Plugging in a Wacom Graphire4 A6 to USB port causes jump to KDL.

This happens with hrev52379 x64 Anyboot (non-EFI) on a Ryzen box: MSI B350M Bazooka Ryzen5 2400G 8GB ram

Plugged into the front USB port which is 3.0, though set to Legacy support inside BIOS.

This issue does not happen at all on hrev52379 x64 on a Sony Vaio VGN-SR19XN, where can plug/unplug and use the tablet without issues. Though Vaio's USB ports are all 2.0.

Thanks Regards, RR

Attachments (2)

IMG_20181004_133811689_BURST001.jpg (2.7 MB ) - added by roiredxsoto 21 months ago.
Screen capture of KDL data
wacom-tablet-smap-kdl.jpg (4.5 MB ) - added by return_0e 14 months ago.
Wacom Bamboo SMAP KDL

Change History (13)

by roiredxsoto, 21 months ago

Screen capture of KDL data

comment:1 by roiredxsoto, 21 months ago

Syslog after hardware force shutdown as result to KDL: https://dev.haiku-os.org/attachment/ticket/11793/20181004-syslogAfterNewBoot

Previous syslog, presumed when landing on KDL: https://dev.haiku-os.org/attachment/ticket/11793/20181004-previous_syslogKDL

comment:2 by waddlesplash, 21 months ago

Unfortunately the KDL is cut off, so it's hard to tell what the problem is.

in reply to:  2 comment:3 by roiredxsoto, 21 months ago

Replying to waddlesplash:

Unfortunately the KDL is cut off, so it's hard to tell what the problem is.

I'll try again and see if there is more and post back, but as far as I know, that image is all that comes out :( Thanks waddlesplash. Regards, RR

Tried again. What happened is:

  • Ryzen box up and running "fine".
  • Plugged the Wacom, did not jump to KDL, but rendered USB ports unusable, and the light on the Wacom that indicates that is "powered on" was blinking.
  • Unplugged the Wacom, no KDL yet, but USB ports still unusable
  • Plugged back the Wacom again, no KDL yet, but this time no light on the Wacom (used both front ports to check just in case)
  • As no KDL yet, just pressed the power button to turn off the box, it did without issues
  • Boot with Wacom plugged in to one of those USB ports. Haiku boots, loads modules and before showing desktop, lands on KDL with exactly the same KDL info as in the previous image. There is no more KDL info available showing on the display. Previous image was not cropped, just uploaded as is.

Thanks again. Regards, RR

Last edited 21 months ago by roiredxsoto (previous) (diff)

comment:4 by diver, 21 months ago

Component: - GeneralDrivers/Input/Wacom
Owner: changed from nobody to stippi

comment:5 by diver, 21 months ago

Owner: changed from stippi to korli
Status: newassigned
Summary: Wacom Graphire4 A6Wacom Graphire4 A6: SMAP violation

comment:6 by waddlesplash, 14 months ago

Owner: changed from korli to stippi

The changes to fix the kernel driver look pretty trivial, but I wonder if this is perhaps a good time to get rid of the kernel driver entirely, and let the Wacom input server addon use the USB Kit directly. stippi, maybe you'll have some time to look into this over the next few months?

comment:7 by return_0e, 14 months ago

Same SMAP violation issue occurs on hrev53102 whilst attempting to plug in a Wacom Bamboo tablet.

Last edited 14 months ago by return_0e (previous) (diff)

by return_0e, 14 months ago

Attachment: wacom-tablet-smap-kdl.jpg added

Wacom Bamboo SMAP KDL

comment:8 by diver, 10 months ago

Same SMAP violation on Panasonic FZ-G1.

comment:9 by diver, 7 weeks ago

Blocking: 16083 added

comment:10 by waddlesplash, 3 weeks ago

Resolution: fixed
Status: assignedclosed

Fixed in hrev54343.

comment:11 by pulkomandy, 2 weeks ago

Milestone: UnscheduledR1/beta3

Moving closed tickets to beta3

Note: See TracTickets for help on using tickets.