Opened 2 months ago

Closed 2 months ago

Last modified 2 months ago

#14609 closed bug (invalid)

Sound stopped working with hrev 52295+100

Reported by: T.Knez Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Audio & Video Version: R1/beta1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86-64

Description

Sound stopped working on my Thinkpad X61s with the latest version of R1/beta1. Currently running hrev 52295+100 with no working sound. Reverting to a state where hrev 52295+96 is active makes sound work again out of the box on the X61s.

Change History (7)

comment:1 Changed 2 months ago by waddlesplash

There aren't any commits in that range that would affect HDA at all. Are you sure that it didn't work before only due to a "warm reboot" from another OS?

comment:2 Changed 2 months ago by T.Knez

The Thinkpad in question runs Haiku exclusively, so that can't be the reason why I'm having this issue. I'm going to try to boot the latest R1/beta1 from USB to see if it's just my install that's acting up for some reason.

comment:3 Changed 2 months ago by T.Knez

Tried with a fresh install with 52295+100 and the problem persists. No sound, but works in 52295+96. Tested with cold boots every time. Haiku is the only OS on the machine.

comment:4 Changed 2 months ago by waddlesplash

That doesn't seem to make any sense at all. Can you please paste syslogs from both boots?

comment:5 Changed 2 months ago by T.Knez

I messed up somehow. BeAE was the culprit all along. Removing BeAE from the system gave me sound back, both in +96 and +100. Ticked can be closed/deleted etc.

comment:6 Changed 2 months ago by korli

Resolution: invalid
Status: newclosed

comment:7 Changed 2 months ago by humdinger

If that is reproducible, an issue should be opened at BeAE, I suppose.

Note: See TracTickets for help on using tickets.