Opened 2 months ago

Closed 2 months ago

Last modified 2 months ago

#14618 closed bug (duplicate)

Network settings window is not refreshed when enabling / disabling services.

Reported by: hitech Owned by: pulkomandy
Priority: normal Milestone: Unscheduled
Component: Preferences/Network Version: R1/Development
Keywords: Services, status Cc:
Blocked By: #11925 Blocking:
Has a Patch: no Platform: x86-64

Description

The list of network services, located at the left part of the Network Preferences window, is not refreshed when user starts or stops a service. See example at the pictures below:

On the first screenshot, I'm running the Telnet service. It runs Ok, the button says "Disable", and the status of Telnet service in the list shows "on".

On the second screenshot, I've clicked "Disable". The Telnet server is disabled, the button says "Enable", but in the list of the services the status of Telnet service is still "on" (look where the cursor is pointing).

Possibly an easy bug. When I close and reopen the window, the status is correct; the code that reads the statuses is fine, it just needs to be called when the button is clicked.

Attachments (2)

screenshot13.png (44.4 KB) - added by hitech 2 months ago.
The Telnet server is running, its status is "on".
screenshot14.png (45.0 KB) - added by hitech 2 months ago.
The Telnet server is disabled, but its status is still "on".

Download all attachments as: .zip

Change History (7)

Changed 2 months ago by hitech

Attachment: screenshot13.png added

The Telnet server is running, its status is "on".

Changed 2 months ago by hitech

Attachment: screenshot14.png added

The Telnet server is disabled, but its status is still "on".

comment:1 Changed 2 months ago by hitech

The platform is x86_64, because this is the hardware I have; Haiku is running on a real computer. Existence of this bug in x86 should be verified.

The version of Haiku is x86_64 R1/beta1+100 (hrev52295+100).

Last edited 2 months ago by hitech (previous) (diff)

comment:2 Changed 2 months ago by TheClue

Pls see also #14553

comment:3 Changed 2 months ago by humdinger

Blocked By: 11925 added
Resolution: duplicate
Status: newclosed

And #11925... :P

comment:4 Changed 2 months ago by TheClue

so many tickets, duplicates are always round the corner '

comment:5 in reply to:  4 Changed 2 months ago by hitech

Replying to TheClue:

so many tickets, duplicates are always round the corner '

I've actually searched for the duplicates, the problem is that everyone uses slightly different words, so I found none dups.

Note: See TracTickets for help on using tickets.