Opened 2 months ago

Last modified 2 months ago

#14627 new bug

install created settings/network/interface file, omitting valid interface

Reported by: donn Owned by: axeld
Priority: normal Milestone: Unscheduled
Component: Servers/net_server Version: R1/beta1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Installing hrev1/beta1 from USB, I first ran Network Prefs to see how it looked for my Ethernet devices. I have 3 - two nvidia built in, which get nforce drivers that have never worked, and a Realtek RTL8139. Just to see, I moved the cable from the rtl8139/0 device to the nforce/0 adapter, and poked at it in Network Prefs, gave it a static address, tried DHCP. Didn't work, OK. I then installed to hard disk.

The installed OS now has system/settings/network/interface file, with ONLY the nforce/0 device in it, and of course that's now the only network option, my rtl8139/0 that actually works and has a cable is gone.

To fix, I removed system/settings/network/interface, and installed again with a fresh hrev1/beta1 copy on USB. If I left that file there, it overrode the install. I guess the bug here is that an interface file masks the existence of other network devices - maybe the creation of an incomplete interface file was an error, but in any case if I plug in a new Realtek card, I need to delete that file if it exists?

The interface was just "interface /dev/net/nforce/0 { address inet { auto_config true } }" (except for white space.)

The nforce driver is busy with lots of configuration in syslog, nothing jumps out at me as an error, but if I remember right it doesn't work in FreeBSD either.

Change History (2)

comment:1 Changed 2 months ago by diver

Component: - GeneralServers/net_server
Owner: changed from nobody to axeld

Looks like a dupe of #6423.

comment:2 Changed 2 months ago by kallisti5

#14626 (which I just opened) could also be related.

We don't handle multiple network cards well! :-)

Last edited 2 months ago by kallisti5 (previous) (diff)
Note: See TracTickets for help on using tickets.