Opened 12 years ago

Closed 11 years ago

#1466 closed bug (fixed)

GUI doesn't redraw / freezes

Reported by: marcusoverhagen Owned by: axeld
Priority: high Milestone: R1
Component: Servers/app_server Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

The GUI (different apps) stops redrawing after resizing a column in tracker a couple of times (make the colum really small and large again).

Reproduceable with hrev22206, screenshots attached.

Attachments (2)

tracker_freeze_on_column_resize.png (33.9 KB) - added by marcusoverhagen 12 years ago.
gui_freeze_on_column_resize.png (29.6 KB) - added by marcusoverhagen 12 years ago.

Download all attachments as: .zip

Change History (7)

Changed 12 years ago by marcusoverhagen

Changed 12 years ago by marcusoverhagen

comment:1 Changed 12 years ago by marcusoverhagen

[14:39] <Begasus> can't reproduce it here ... [14:40] <Begasus> resized the tracker colums a few times and the tracker window and terminal window still draw ok here ... [14:42] <dr_evil> try making the column disappear a few times [14:42] <Begasus> err ... nevermind that one ... [14:42] <Begasus> yep probs ... [14:46] <Begasus> http://www.flickr.com/photos/begasus/1350798368/

comment:2 Changed 12 years ago by marcusoverhagen

This appears to be the Tracker thread "w>Haiku" running at a priority of 15. When setting it to lower priority, the Terminal starts drawing again, but the Deskbar will remain frozen.

F12 => prio 5 => cont

comment:3 Changed 11 years ago by jackburton

There was a problem with _BWidthBuffer_, used by Tracker's PoseView, which could've caused this problem. It was was fixed in hrev24096. I can't reproduce this problem anymore. Can someone confirm ?

comment:4 in reply to:  3 Changed 11 years ago by tigerdog

Replying to jackburton:

There was a problem with _BWidthBuffer_, used by Tracker's PoseView, which could've caused this problem. It was was fixed in hrev24096. I can't reproduce this problem anymore. Can someone confirm ?

I tried to cause the problem under revision 24493 but could not duplicate. I resized the "Filename" column back and forth for > 60 seconds. Display sometimes lagged but never froze.

comment:5 Changed 11 years ago by axeld

Resolution: fixed
Status: newclosed

This one has apparently been fixed.

Note: See TracTickets for help on using tickets.