Opened 7 months ago

Closed 7 months ago

Last modified 6 months ago

#14667 closed bug (fixed)

Deadlock with ipro100 and iprowifi2100

Reported by: hugeping Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Drivers/Network/ipro100 Version: R1/Development
Keywords: freeze Cc:
Blocked By: Blocking: #14702
Has a Patch: no Platform: All

Description

My 32-bit system is stucked on boot (x86_gcc2) on blank background. KDL can not be invoked from keyboard.

But i can reproduce this only on haiku.hpkg from repos. When i build haiku.hpkg myself all seems working fine. This is very strange.

Moreover, blacklisting ipro100 _OR_ ipwifi2100 solve the problem. (Both adapters exist in my machine, wifi - configured, wired -- not configured).

If blacklisting ipro100 and then add it via non-packaged on running system it freezes too (after 3-5 seconds).

If blacklisting ipwifi2100 and then add it via non-packaged on running system it works ok.

On my build all works fine without blacklisting...

I have attached images (ok/ -- my own build, problem/ -- with problem) :)

The system is pentium. 1 logical CPU.

If i try to invoke KDL from keyboard just before freeze, i often got

vm_page_allocate_page_run + 0x46c in backtrace...

Attachments (4)

images.zip (2.1 MB) - added by hugeping 7 months ago.
image files
images-ok.zip (1.1 MB) - added by hugeping 7 months ago.
iprowifi2100 (526.6 KB) - added by taos 6 months ago.
iprowifi2100 binary (gcc2 hybrid, hrev 52547)
syslog (468.5 KB) - added by taos 6 months ago.
syslog (incl. booting without and with blacklisted iprowifi2100) from hrev52547

Change History (19)

Changed 7 months ago by hugeping

Attachment: images.zip added

image files

comment:1 Changed 7 months ago by hugeping

More info. I loaded with blacklisted ipro100. Added it to non-packaged. Wait 3 sec and invoked KDL from keyboard. I got same backtrace with vm_page_allocate_page_run + 0x46c

Same, that i got while booting: https://dev.haiku-os.org/attachment/ticket/14660/backtrace.jpg

After cont from kdl i got freeze in 1-2 sec.

May be there is the forever loop in that function?

Last edited 7 months ago by hugeping (previous) (diff)

comment:2 Changed 7 months ago by Coldfirex

What rev?

comment:3 Changed 7 months ago by hugeping

Images are from 52460.

comment:4 Changed 7 months ago by waddlesplash

It would be interesting to get a new images.zip (you can replace the current one) post-hrev52467, as after that the symbol names will be much closer to one another (if you can replicate the buildbot setup on your own machine, i.e. have a generated directory that has a relative path to the haiku checkout of ../../haiku/ and then build the kernel and drivers, this should produce nearly identical binaries).

comment:5 Changed 7 months ago by hugeping

After todays git pull and ../configure --update i can't build myselff anymore:

../build/scripts/build_archive: 21: .: haiku-floppyboot-init-vars: not found

Will try dig it...

P.S. changed . $1 to . ./$1 in build_archive but then got another error... do not know what happens...

P.P.S. changed another . to ./ and build started... can you give me more info about buildbot config? what can i reproduce it?

P.P.P.S the . -> ./ problem raises again and again... i will try rebuild all from scratch, but it will take time..

Last edited 7 months ago by hugeping (previous) (diff)

comment:6 Changed 7 months ago by waddlesplash

I saw that occuring on one buildbot configuration but not another. I didn't manage to reproduce it locally; I'll have to try again...

Try building just "haiku.hpkg", this will avoid the loader altogether.

comment:7 Changed 7 months ago by waddlesplash

That issue should be fixed in hrev52474.

Changed 7 months ago by hugeping

Attachment: images-ok.zip added

comment:8 Changed 7 months ago by hugeping

Ok. Today i have upgraded on 52467 and deadlock is gone. :)

comment:9 Changed 7 months ago by waddlesplash

Resolution: fixed
Status: newclosed

That's... interesting. Maybe it's something related to anonymous symbols then. Keep an eye on it, at any rate.

comment:10 Changed 6 months ago by taos

I'm not sure if that's the same underlying problem: Since the update to hrev52525 I have to blacklist my iprowifi2100 to be able to boot to the desktop. Otherwise, I'm infinitely stuck on the slightly distorted image I usually see between the last moment of the boot screen (incl. the rocket) and the first glimpse of the blank background.

comment:11 Changed 6 months ago by waddlesplash

Does the same behavior as in the ticket hold -- i.e. you only need to blacklist either ipro100 or iprowifi2100, but not both, or one specifically? If so, please upload the exact binaries on your system.

comment:12 Changed 6 months ago by taos

I have to blacklist the iprowifi2100. Blacklisting only the ipro100 does not get me to the desktop. However, there's no ipro100 adapter in my laptop, so, this may be expected? Nevertheless, I'll attach the syslog and iprowifi2100 binary extracted from hrev52547.

Changed 6 months ago by taos

Attachment: iprowifi2100 added

iprowifi2100 binary (gcc2 hybrid, hrev 52547)

Changed 6 months ago by taos

Attachment: syslog added

syslog (incl. booting without and with blacklisted iprowifi2100) from hrev52547

comment:13 Changed 6 months ago by hugeping

Please try to blacklist broadcom440x and check if it will stuck or not...

Last edited 6 months ago by hugeping (previous) (diff)

comment:14 Changed 6 months ago by waddlesplash

Blocking: 14702 added

comment:15 Changed 6 months ago by taos

Blacklisting broadcom440x doesn't let me boot to the desktop but a warm boot from Windows XP (after all those years running Linux, BeOS and Haiku, it's actually still set as default for grub on that laptop).

Note: See TracTickets for help on using tickets.