Opened 10 months ago

Last modified 5 months ago

#14718 new bug

System freezes on shutdown, but reboot works fine.

Reported by: bullfrog Owned by: yongcong
Priority: normal Milestone: Unscheduled
Component: Drivers/Power Version: R1/beta1
Keywords: Cc: tqh
Blocked By: Blocking:
Has a Patch: no Platform: x86-64

Description

Beta1, 64bit, most recent system update. My HP Pavilion G6 laptop freezes at shutdown time at the dialog after applications quit, no mouse, no keyboard, no shutdown. This behavior happens with both Power Off from the shutdown menu, and shutdown from the terminal. "shutdown -q" results in instant freeze, loss of keyboard and mouse. If I let the system run at this point, it overheats and goes into thermal shutdown, even with my extra cooling fans running. This is the only time I get overheating on this box, on any operating system. I tried a Beta1 32bit on the system, same issue.

Rebooting works excellent, no freezes, quick reboot.

Change History (9)

comment:1 by waddlesplash, 10 months ago

Cc: tqh added
Component: - GeneralDrivers/Power
Owner: changed from nobody to yongcong

comment:2 by bullfrog, 9 months ago

Update: I found one more instance where this same type of thermal overload occurs in Haiku. Whenever I'm building within the Haiku tree (using jam), I get an identical type of system lockup, resulting in same thermal shutdown. This doesn't occur when building ports and such with build systems other than jam. Using -j4 or -j2 results in a lockup within a couple minutes. Using -j1 seems to delay it for about an hour, but does eventually occur. I'm not sure if that warrants a separate ticket.

Last edited 9 months ago by bullfrog (previous) (diff)

comment:3 by bullfrog, 9 months ago

Going from hrev52711 to hrev52715 seems to fix this.

Last edited 9 months ago by bullfrog (previous) (diff)

comment:4 by bullfrog, 9 months ago

Only solved for one scenario, which was a different machine than as posted. The bug as posted is still present for the machine I originally posted about.

Last edited 9 months ago by bullfrog (previous) (diff)

comment:5 by waddlesplash, 7 months ago

Blocking: 14887 added

comment:6 by cocobean, 6 months ago

Usually, the thermal dissipation is compromised or you have a hardware defect in the CPU/motherboard. Professionally cleaning and updating the BIOS can solve a few problems, but a elusive hardware (CPU) defect might be the real issue. Thermal shutdown usually means something is wrong in cooling or a hardware error.

comment:7 by tqh, 6 months ago

As I mentioned in https://dev.haiku-os.org/ticket/14954#comment:5 this is more likely a problem with the machine firmware and Haiku not implementing quirks for broken hardware. It also not likely to happen as we don't have resources or hardware to fix these.

comment:8 by tqh, 6 months ago

Blocking: 14887 removed

Also this is very unlikely to block #14887 in any way.

comment:9 by waddlesplash, 5 months ago

bullfrog, please retest with a recent nightly. My changes to interrupt asserts and locking may prevent some deadlocks here.

Note: See TracTickets for help on using tickets.