Opened 2 weeks ago

Closed 10 days ago

Last modified 9 days ago

#14726 closed bug (fixed)

KDL: SMAP violation (sshfs_fuse)

Reported by: diver Owned by: korli
Priority: normal Milestone: Unscheduled
Component: File Systems/UserlandFS Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

hrev52597.

To reproduce:

pkgman ins ssh_fuse
mkdir /mnt
echo password | /system/servers/userlandfs_server sshfs

In another console:

mount -t userlandfs -o 'sshfs user@server:./ -o password_stdin' /mnt

Double click newly mounted volume on the Desktop.

Attachments (3)

smap.png (35.3 KB) - added by diver 2 weeks ago.
area.png (26.5 KB) - added by diver 13 days ago.
area2.png (15.1 KB) - added by diver 11 days ago.

Download all attachments as: .zip

Change History (18)

Changed 2 weeks ago by diver

Attachment: smap.png added

comment:1 Changed 2 weeks ago by waddlesplash

I'm not sure why this ticket is assigned to me...

Anyway, I've seen the "read fault" in a backtrace only once before, in a KDL in the USB MIDI driver. Any other evidence of it? Because i have no idea where to begin investigating that.

comment:2 Changed 2 weeks ago by waddlesplash

Owner: changed from waddlesplash to korli

comment:3 Changed 13 days ago by korli

diver, you can probably give more information:

Here is the help for the area debugger command: https://github.com/haiku/haiku/blob/9cc0f06a015202f58ae669f0bf7653e66161d7e2/src/system/kernel/vm/vm.cpp#L3319

"area contains <address>" should show which area is causing SMAP to trigger.

Thanks!

Changed 13 days ago by diver

Attachment: area.png added

comment:4 Changed 13 days ago by diver

Since I didn't know what address to use I used both from the panic message.

comment:5 Changed 13 days ago by korli

comment:6 Changed 12 days ago by diver

Thanks! I only needed to add #include <vm/vm.h> to make it to compile with jam userland_fs.hpkg and now it works just fine!

comment:7 Changed 12 days ago by diver

Component: - GeneralFile Systems/UserlandFS

comment:8 Changed 12 days ago by korli

comment:9 Changed 12 days ago by axeld

Please try again with hrev52604 or later.

comment:10 Changed 11 days ago by diver

Listing files works now, however trying to open a file results in another crash.

Changed 11 days ago by diver

Attachment: area2.png added

comment:11 Changed 10 days ago by korli

Isn't there a complete stack trace?

comment:12 Changed 10 days ago by diver

Unfortunately no, stack trace just suddenly ends with [*** READ/WIRITE FAULT (?)]. Running bt about 5 times simply reboots VMware VM.

comment:13 Changed 10 days ago by korli

Please check with hrev52612 or newer.

About the stacktrace, I disabled locally print_demangled_call() in src/system/kernel/arch/x86/arch_debug.cpp to workaround the effect of SMAP. Needs more investigation.

comment:14 Changed 10 days ago by diver

Resolution: fixed
Status: assignedclosed

Confirmed fixed. Thanks!

comment:15 Changed 9 days ago by korli

For reference, the follow-up on the stacktrace problem is https://review.haiku-os.org/#/c/haiku/+/742/ (not SMAP related after all).

Note: See TracTickets for help on using tickets.