Opened 12 years ago

Closed 11 years ago

#1473 closed bug (fixed)

Haiku doesn't boot in a HD (KDL)

Reported by: franxico Owned by: mmlr
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I just tried the hrev22224 in my machine and i get into the KDL.

my specs: CPU ID (80000002..4) Processor Name "AMD Athlon(tm) XP 1700+" MB Matsonic MS8137C ATX - VIA Apollo KT266A - Socket A 512MB of RAM Radeon 7000 AGP HD PATA Samsung 80GB There's also an USB 2.0 PCI card and a D-Link DFE-528TX network adapter.

Haiku was installed in a 2GB extended partition.

I used mkbfs and makebootable from Zeta 1.21.

Attachments (1)

Haiku KDL.JPG (231.8 KB) - added by franxico 12 years ago.
Photo of the bt from the KDL

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by franxico

Attachment: Haiku KDL.JPG added

Photo of the bt from the KDL

comment:1 Changed 12 years ago by stippi

Owner: changed from axeld to mmlr

Seems like the usb_hid is being loaded and invokes a panic. Maybe Michael has an idea?

Does this happen every single time? Does booting without USB Mouse or Keyboard work fine?

comment:2 Changed 12 years ago by franxico

It happened a lot of times, but now it boots!

Let me try to explain what i did. I have a DVB-T device, a HP Deskjet 5550 and a extension cord plugged in the VT6212 USB2.0 card. I just unplugged all of them and Haiku works now. The odd thing is, if I plug them back, Haiku continues to boot. So unfortunately I can't reproduce the crash. Should I close the ticket?

Thanks anyway.

comment:3 Changed 12 years ago by mmlr

Status: newassigned

From the stack trace it doesn't actually crash when trying to use usb_hid. It loads the USB stack and tries to setup a UHCI controller but fails. Then something goes wrong when uninitializing the failed attempt. Most probably it's an OHCI device which explains why the UHCI controller fails to setup, but it of course shouldn't crash. I'll see if there's something dangerous going on in the error conditions.

comment:4 Changed 11 years ago by mmlr

There were a few variables added for isochronous support which are not cleared when creating the UHCI bus. It's possible that this caused the crash when a not completely initialized UHCI bus was deleted. The question remains why it would fail to setup in the first place. Do you have UHCI USB 1.1 ports in that machine? Do they work under Haiku? I will look into sanitizing those variables and then close this bug if it is not reproducible anymore.

comment:5 Changed 11 years ago by mmlr

Resolution: fixed
Status: assignedclosed

Anyway, fixed the initialization with hrev24954. Closing as this seems to not be reproducible anymore.

Note: See TracTickets for help on using tickets.