Opened 4 months ago

Last modified 3 months ago

#14748 new bug

HaikuDepot - Register - Email Address Rejected

Reported by: JohnGoold Owned by: haiku-web
Priority: normal Milestone: Unscheduled
Component: Sys-Admin Version: R1/Development
Keywords: haikudepot, register, email Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When attempting to register for HaikuDepot, the registration is rejected if the email address does not meet some standard set by Haiku-OS.org. I understand that some kind of tests should be done in an attempt to filter SPAM/Bot attempts to register, but perfectly normal addresses should not fail. The filtering is too coarse.

It should not be necessary to use one of the (expletive deleted) "free" email services such as Gmail, Hotmail, AOL, Yahoo! mail.

[Aside] I registered a domain name decades ago (at the very beginning of public accessibility to the Internet via the World-Wide Web). I did so after my ISP was absorbed by a larger company and I had to change my email address. I vowed that would never happen again. I registered mylastname.net and setup an email account, myfirstname@…

There are many (thousands? tens of thousands? hundreds of thousands?) people who do something similar. Some use a domain name that reflects a small business, some their hobby,... Aside

So, the filter being used is too coarse. There is something wrong when

jrg.public@goold.net

is filtered out as suspected Spam.

I still use that (and others).

Change History (2)

comment:1 Changed 4 months ago by humdinger

This should be reported to https://github.com/haiku/haikudepotserver. Registering with that email address in the HaikuDepot application works.

comment:2 Changed 3 months ago by JohnGoold

I had originally attempted to register using HaikuDepot, but ran into problems because it was not clear what the restrictions on User Names and Passwords were. I think that the app got into a strange state after all the errors and retries and flagged my email address erroneously.

It would be pretty difficult for me to reproduce this problem, so I suggest treating it as a "one-off" anomaly. If someone else runs into the problem, it can be addressed then. I suspect it should be low priority as once one has figured out the restrictions on User-Ids and Passwords, one can always launch HaikuDepot fresh (doing a reboot if necessary) and then go through the registration without having a lot of errors and retries.

By the way, in case it is not obvious, I re-tried the registration after @humdinger's comment and was able to register — thank you @humdinger!

Note: See TracTickets for help on using tickets.