Opened 20 months ago

Closed 6 months ago

Last modified 4 months ago

#14786 closed bug (invalid)

mesa_swpipe 17.1.10-3 misrenders Mesa's gearbox demo

Reported by: cocobean Owned by: kallisti5
Priority: normal Milestone: Unscheduled
Component: Kits/OpenGL Kit/Software Pipe Version: R1/Development
Keywords: swpipe, mesa, opengl Cc:
Blocked By: Blocking:
Platform: All

Description

Mesa's gearbox demo from Mesa demos is misrendered with a few black box images versus the correct textures with spinning gears.

Src: https://cgit.freedesktop.org/mesa/demos/tree/src/demos/gearbox.c?id=317f67fe5e75c685330d536f158acf6260b473d1

Attachments (2)

gearbox.png (12.5 KB ) - added by cocobean 20 months ago.
Mesa Demo 8.4.0 - Gearbox demo image misrendering in Haiku Mesa 17.1.10-3
screenshot3.png (48.1 KB ) - added by X512 6 months ago.
No problem with my mesa-19.3.3 port

Download all attachments as: .zip

Change History (6)

by cocobean, 20 months ago

Attachment: gearbox.png added

Mesa Demo 8.4.0 - Gearbox demo image misrendering in Haiku Mesa 17.1.10-3

comment:1 by cocobean, 6 months ago

Haiku R1B1 / mesa 17.1.10-6 (x86_64): same result

by X512, 6 months ago

Attachment: screenshot3.png added

No problem with my mesa-19.3.3 port

comment:2 by X512, 6 months ago

Mesa3D port including Haiku specific parts is located in HaikuPorts, it's better to report issue there.

comment:3 by waddlesplash, 6 months ago

Resolution: invalid
Status: newclosed

Indeed.

comment:4 by nielx, 4 months ago

Remove milestone for tickets with status = closed and resolution != fixed

Note: See TracTickets for help on using tickets.