#14796 closed bug (duplicate)

Build fails at creating haiku_source.hpkg

Reported by: bullfrog Owned by: bonefish
Priority: normal Milestone: Unscheduled
Component: Build System Version: R1/Development
Keywords: Cc:
Blocked By: #10815 Blocking:
Has a Patch: no Platform: All

Description

Can be duplicated in most hrev52711 and beta1. Basic/plain ./configure; jam -j4

AddExtractFileToContainerExtractFilesScript <HaikuImage>haiku.image-extract-files-dummy-home/config/settings/WebPositive-src/apps/webpositive/bookmarks/WebPositiveBookmarks.zip

haiku.hpkg: mimeset'ing package contents ...

haiku.hpkg: Creating the package ...

haiku_source.hpkg: mimeset'ing package contents ...

haiku_source.hpkg: Creating the package ...

BUILD FAILURE:

...failed updating 1 target(s)...

...skipped 25 target(s)...

...updated 1293 target(s)...

Attachments (1)

jam fail (149.6 KB ) - added by bullfrog 11 months ago.
Full output of last build attempt.

Download all attachments as: .zip

Change History (5)

comment:1 by waddlesplash, 11 months ago

It appears to have succeeded in making the package. "Failed updating 1 targets" doesn't mean it's the last target that failed, only that one of the targets failed.

Please attach a text file with the full build output.

by bullfrog, 11 months ago

Attachment: jam fail added

Full output of last build attempt.

comment:2 by waddlesplash, 11 months ago

ld: generated/objects/haiku/x86_64/release/system/boot/platform/bios_ia32/bios_ia32/boot_platform_bios_ia32.o: in function `BIOSDrive::WriteAt(void*, long long, void const*, unsigned long)':
	(.text+0xff0): undefined reference to `__divmoddi4'
...

This is the actual problem. It looks like your cross-tools don't contain a working 32-bit libgcc.

Are you building Haiku on Haiku?

comment:3 by bullfrog, 11 months ago

Haiku on haiku. This has been occurring on a couple fresh git clones on both beta and the last 3 or so nightly hrevs. All 64bit. Should I be specifying x86_64 in the ./configure? This could be the problem? I don't recall having to do so on previous successful builds. But those were on a different box.

comment:4 by waddlesplash, 11 months ago

Blocked By: 10815 added
Resolution: duplicate
Status: newclosed

Then this is just a duplicate of #10815. The problem is that our "gcc" package does not include multilib (32-bit) libraries. You can work around this by just building the cross-tools, as one must do on non-Haiku platforms also.

Note: See TracTickets for help on using tickets.