Opened 11 days ago

Last modified 11 days ago

#14801 new bug

Default mail app refuses to check my inbox and fails when trying to configure the folders

Reported by: mpxlbs Owned by: czeidler
Priority: normal Milestone: Unscheduled
Component: Applications/Mail Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by diver)

Using hrev52713 x64 in UEFI mode.

I use One.com and have been for about 3-4 years now. Their server settings are:

imap v4
imap.one.com:ssl:993
send.one.com:ssl:465
Use Authentication: Yes
Use SSL/TLS/STARTTLS: Yes

Set up the e-mail application as follows.

Accounts
 MyEmail@MyDomain.CC
  Account name:  MyEmail@MyDomain.CC
  Real Name: MyRealName
  Return address:  MyEmail@MyDomain.CC

 Incoming
  Imap
   Mail server: imap.one.com
   Username:  MyEmail@MyDomain.CC
   Password: MyRandomGeneratedPassword
   Connection type: SSL
   [x] Remove mail from server when deleted
   [  ] Partially download messages larger than [ ]
   Destination: /boot/home/mail/in

 Outgoing
  SMTP server: send.one.com
  Username:  MyEmail@MyDomain.CC
  Password: SameAsIncoming
  Connection type: SSL
  Login type: ESMTP
  Destination: /boot/home/mail/out

Settings
 [X] Check every [5] minutes
 Show notifications [While sending and receiving.

No mails can be received. Mail folder configuration not downloaded.

Under incoming, I can select

Configure IMAP Folders

Doing so results in

Imap Folders
 Failed to fetch available storage
  Could not connect to server "imap.one.com:
  Invalid Argument.

Syslog does not show any relevant errors that I can see. Where would I look for them? Maybe you can see them.

Attachments (1)

syslog (59.5 KB) - added by mpxlbs 11 days ago.
Syslog output file.

Download all attachments as: .zip

Change History (5)

Changed 11 days ago by mpxlbs

Attachment: syslog added

Syslog output file.

comment:1 Changed 11 days ago by humdinger

You may find useful info by starting the mail_daemon from Terminal. As it's auto-restarted by the launch_daemon, you'll have to stop it first, before starting it from Terminal:

launch_roster stop x-vnd.Be-POST
/boot/system/servers/mail_daemon

Make sure the mail_daemon isn't still running after stopping the service by checking with ProcessController.

comment:2 Changed 11 days ago by diver

Description: modified (diff)
Keywords: mail removed

comment:3 Changed 11 days ago by diver

Description: modified (diff)

comment:4 Changed 11 days ago by mpxlbs

I'm not going to output what the terminal said, because it lists my entire password in plain text.

However, I think the problem might be that since I use a random generated password with every character available, except for spaces, that might be the problem, because:

OK [CAPABILITY IMAP4rev1 LITERAL+ SASL-IR LOGIN-REFERRALS ID ENABLE IDLE AUTH=PLAIN] Dovecot ready. CAPABILITY: IMAP4rev1, LITERAL+, SASL-IR, LOGIN-REFERRALS, ID, ENABLE, IDLE, AUTH=PLAIN A0000010 BAD Invalid characters in atom worker quit

Above that are my login details.

My password is over 32 characters in length and is generated by keepass.

Last edited 11 days ago by mpxlbs (previous) (diff)
Note: See TracTickets for help on using tickets.