Opened 8 weeks ago

Closed 5 weeks ago

Last modified 5 weeks ago

#14927 closed bug (no change required)

HaikuDepot doesn't show any packages

Reported by: KapiX Owned by: apl-haiku
Priority: normal Milestone: Unscheduled
Component: Applications/HaikuDepot Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Since some time HaikuDepot doesn't show any packages on my machine. What's interesting is that while loading they are visible but then disappear, like some kind of filter (search perhaps) was applied. Searching for something else doesn't help. There were three Qt packages visible (installed from local hpkg IIRC), but since I uninstalled them the list is empty. I tried removing local settings but it didn't help. I have selected to show packages from all repositories.

I can provide logs but I need to know which ones.

Attachments (1)

log.txt (14.6 KB) - added by KapiX 8 weeks ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 8 weeks ago by waddlesplash

Owner: changed from stippi to apl-haiku
Status: newassigned

comment:2 Changed 8 weeks ago by apl-haiku

That is strange. I have just played around with it locally and it seems to be working fine. Can you please first of all provide a console log and attach it here. I can perhaps see if there are any clues from that.

Secondly, try to moved the ~/config/cache/HaikuDepot somewhere else (eg; add an underscore to the directory) and re-load HaikuDepot. Does this have any effect?

Third, with the Qt packages, do I understand correctly...

  1. Take the three Qt packages and drop them into /system/packages
  2. Load HD and observe the packages loading correctly in the UI
  3. Quit HD
  4. Remove the three Qt packages from /system/packages
  5. Load HD and observe the problem

Are you able to easily try this again to see if this is the problem at your end or give me the three "hpkg" files?

comment:3 Changed 8 weeks ago by waddlesplash

I just realized that HDS was down at the time this ticket was created, but service was restored about 7 hours ago now. So perhaps that's the difference.

comment:4 Changed 8 weeks ago by apl-haiku

Hello @waddlesplash; Thanks for the pointer. I did not see any outage information in the mailing list; is there an alert for HDS being offline and do you know what was the cause for the outage?

I guess if that were happening, the desktop application should have been able to run off cached data just fine. I've tested that.

@KapiX are you able to confirm that you are still seeing the problem now that HDS is operational.

comment:5 Changed 8 weeks ago by KapiX

HDS being operational has nothing to do with it because I'm seeing the issue for a few months now. Anyway it still doesn't work (the package list view).

Moving the cache doesn't fix the issue. I can only see packages for a bit longer. As soon as loading done, packages in the list are gone.

Load HD and observe the packages loading correctly in the UI

No, only those three packages, not all of them. It looks like at some point in time some kind of permanent filter was applied. I don't have the three packages so I can't provide them.

Changed 8 weeks ago by KapiX

Attachment: log.txt added

comment:6 Changed 8 weeks ago by apl-haiku

I wonder if there may be a mismatch on your system with your repositories' identifiers. Can you please do a quick check on this. If you run pkgman list you should see a value for;

  • base-url
  • url

Can you please check that the "url" matches the "url" value from the repository's "repo.info" file. For example from...

https://eu.hpkg.haiku-os.org:443/haikuports/master/x86_64/current/repo.info

...or see HDS is also able to show you those "url" values as well -- see the field with the label "URL (repo.info)".

comment:7 Changed 5 weeks ago by KapiX

Resolution: no change required
Status: assignedclosed

Yes, url for both repos was empty. Readding them fixed it. Thanks.

comment:8 Changed 5 weeks ago by diver

Maybe haikuDepot should at least warn that there are no repositories currently configured in this case?

Note: See TracTickets for help on using tickets.