Opened 7 months ago

Last modified 3 months ago

#14934 new bug

System shuts down when doing a restart

Reported by: BlueSky Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: - General Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

The system is an Acer Aspire 5313 series running Haiku x86_64 nightly. When I do a reboot from the Deskbar menu the system shuts down instead of rebooting. Also the same behaviour when doing a "shutdown -r". The problem is not 100% reproducible, on 1 or 2 times in 20 attempted reboots it works correctly. Also I couldn't pin it down to a specific hrev.

Syslog attached, please let me know if you need more information.

Attachments (1)

syslog (379.4 KB ) - added by BlueSky 7 months ago.

Download all attachments as: .zip

Change History (3)

by BlueSky, 7 months ago

Attachment: syslog added

comment:1 by BlueSky, 3 months ago

"Force Reboot" from TeamMonitor and reboot command from KDL consistently results in a normal reboot.

comment:2 by tqh, 3 months ago

It's a problem with older machines ACPI firmware. Force Reboot and KDL reboot I think is doing the equivalent of CTRL - ALT - DEL (through keyboard controller) IIRC, which does not go through ACPI shutdown/reboot.

Doing this in a way that we don't cause issues anywhere is hard, so therefore work on a unified way for all hw has stopped. Modern hardware seems to work fine. Someone would need to add a fallback flag and do a different shutdown on these old machines. That would most likely involve making sure shutdown is done on the boot cpu.

We did this before, but that caused inter cpu lockups on almost all hardware from time to time when disabling non boot cpu's.

Note: See TracTickets for help on using tickets.