Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#14945 closed bug (fixed)

Beta1 - Realtek network card regression

Reported by: un_spacyar Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Network & Internet Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

After update from Haiku BETA1 52295+117 (x86_gcc2) to hrev52295+129, I get the following issue:

The Network server keep stuck at "Configuring" (gray dot).

My network card is: device Network controller (Ethernet controller) [2|0|0]

vendor 10ec: Realtek Semiconductor Co., Ltd. device 8136: RTL8101/2/6E PCI Express Fast Ethernet controller

Using the previous version (BETA1 52295+117), the network card works perfectly.

I attach the complete listdev output.

Attachments (1)

listDevOutput.txt (3.0 KB) - added by un_spacyar 3 months ago.

Download all attachments as: .zip

Change History (3)

Changed 3 months ago by un_spacyar

Attachment: listDevOutput.txt added

comment:1 Changed 3 months ago by waddlesplash

Resolution: fixed
Status: newclosed

The problem is almost certainly https://git.haiku-os.org/haiku/commit/?h=r1beta1&id=ce20fed52778f50e59cf74b8849ae4fb47dd353c. Reverted in https://git.haiku-os.org/haiku/commit/?h=r1beta1&id=4d350bfad69b84fec9de880dc56a6506905015e7, and will be shipped with the next update.

In the meantime, you can probably delete your "interfaces" file for a quick fix.

comment:2 Changed 3 months ago by un_spacyar

@waddlesplash: thanks! After deleting the "interfaces" file in /system/settings/network, it's working again.

Just curiosity: I noticed that the "interfaces" file is not generated anymore. That configuration file was deprecated?

Note: See TracTickets for help on using tickets.