Opened 7 weeks ago

Closed 7 weeks ago

Last modified 7 weeks ago

#14990 closed bug (fixed)

Unbootable system after an update

Reported by: khallebal Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: - General Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Updated from hrev52983 to hrev53029, system hangs at the rocket icon. syslog attached.

Attachments (1)

previous_syslog (151.5 KB) - added by khallebal 7 weeks ago.

Download all attachments as: .zip

Change History (14)

Changed 7 weeks ago by khallebal

Attachment: previous_syslog added

comment:1 Changed 7 weeks ago by waddlesplash

package_daemon [56424566:   322] Failed to open packages activation file: No such file or directory
package_daemon [56435530:   322] Failed to get activated packages info from activated packages file. Assuming all package files in package directory are activated.

It seems strange that there is no activation file after the upgrade, pkgman should have made one. Are you sure there was not some FS corruption?

comment:2 Changed 7 weeks ago by waddlesplash

Oh, never mind:

package_daemon [50611840:   322] An old packages state ("state_2019-04-04_15:48:42") seems to be active.

You seem to have attached a syslog from the successful boot into the old state. That will not be very helpful in determining what's happening here...

comment:3 Changed 7 weeks ago by waddlesplash

Someone confirmed on IRC that hrev53026 booted OK on their hardware. So if that is truly the case for everyone, the problem must be hrev53027, because hrev53028 & hrev53029 don't touch any code. That doesn't make any sense at all...

comment:4 Changed 7 weeks ago by waddlesplash

Well, bad news: hrev53033 boots just fine here. So I don't know what's going on.

comment:5 Changed 7 weeks ago by khallebal

1650	Launching x-vnd.haiku-app_server failed: Symbol not found
2835	[atheroswifi] (ath) ath_legacy_rx_tasklet: sc_inreset_cnt > 0; skipping

I don't know what make of these 2 lines, the second one is the last in the onscreen debug, the boot process doesn't go farther than that.

comment:6 Changed 7 weeks ago by waddlesplash

runtime_loader: /boot/system/lib/libxml2.so.2.9.9: Could not resolve symbol '__builtin_clzll'
runtime_loader: /boot/system/lib/libxml2.so.2.9.9: Troubles relocating: Symbol not found

Ah, now that explains why I couldn't reproduce: I only update haiku.hpkg, not the XML library.

comment:8 Changed 7 weeks ago by mmu_man

Confirmed here after an update, same missing symbol.

comment:9 Changed 7 weeks ago by waddlesplash

Resolution: fixed
Status: newclosed

comment:10 Changed 7 weeks ago by mmu_man

Fixed in latest update ;-)

comment:11 Changed 7 weeks ago by Evgen

Resolution: fixed
Status: closedreopened

Hello,

I've got the same problem. I updated machine with 32 bit hrev53042 (with hrev53029 and hrev53026 too) and it becomes unbootable. It stops at Haiku Boot Loader debug menu. 1st line says Select boot volume (Current: None). I reverted machine to hrev53013 and it boots normally.

Last edited 7 weeks ago by Evgen (previous) (diff)

comment:12 Changed 7 weeks ago by mmu_man

Please don't post full syslogs inline, it makes reading tickets painful. Please edit your comment to remove it and attach it as a file instead. Besides, if it's the syslog of the working version it's not really useful anyway.

We already confirmed the bug was fixed. Make sure you did update all the packages, and not just the base one, since the bug was in libxml. Make sure you updated libxml2 to 2.9.9-3.

It might not be the same bug. In which case you should open a new ticket instead of reopening this one.

Last edited 7 weeks ago by mmu_man (previous) (diff)

comment:13 Changed 7 weeks ago by waddlesplash

Resolution: fixed
Status: reopenedclosed

Yes, this is not the same bug, there is no "app_server" message. It looks like you have intel_extreme; possibly the recent change there broke things.

Note: See TracTickets for help on using tickets.