Opened 2 weeks ago

Closed 2 weeks ago

#15142 closed bug (fixed)

NULL dereference in console_write

Reported by: SnodBlatter Owned by: korli
Priority: normal Milestone: Unscheduled
Component: Drivers Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Upon closing Netsurf the screen turned white, but moving the cursor around left "refreshed" squares behind which showed the desktop. Deskbar was still responding so I tried to reboot but nothing happened. Hit ctrl+alt+delete (I don't even know if that does anything in Haiku!) and the panic scrolled down the screen. See attached picture.

Specs:

hrev53230

1.3GHz Tualatin Celeron @ 1.6GHz

Asus P2B-F

512MB memory

GF4 MX460

ES1371 sound card

Intel Pro 100 NIC

Currently rolled back to hrev53047 which is rock solid in comparison.

Attachments (4)

190707.JPG (3.4 MB) - added by SnodBlatter 2 weeks ago.
backtrace
netsurf.JPG (2.3 MB) - added by SnodBlatter 2 weeks ago.
haikudepot.JPG (2.0 MB) - added by SnodBlatter 2 weeks ago.
mediaplayer.JPG (1.7 MB) - added by SnodBlatter 2 weeks ago.

Change History (17)

Changed 2 weeks ago by SnodBlatter

Attachment: 190707.JPG added

backtrace

comment:1 Changed 2 weeks ago by waddlesplash

The backtrace is a bit cut off. Can you try to take a picture with the bottom visible, too?

comment:2 Changed 2 weeks ago by waddlesplash

When you say "since June", can you give a more specific hrev or a date that the crashes started occurring on? hrev53225 is a potential culprit but was merged on 1 July.

comment:3 Changed 2 weeks ago by waddlesplash

Owner: changed from nobody to korli
Status: newassigned

Ah, probably hrev53172 is the real culprit.

Changed 2 weeks ago by SnodBlatter

Attachment: netsurf.JPG added

Changed 2 weeks ago by SnodBlatter

Attachment: haikudepot.JPG added

Changed 2 weeks ago by SnodBlatter

Attachment: mediaplayer.JPG added

comment:4 Changed 2 weeks ago by SnodBlatter

hrev53047 is fine, hrev53092 also appears to work fine. I often don't use this machine for 2-3 weeks so it could be any version since then that started it.

Attached are three more panics, the name of the file is what I was running when it happened. Larger programs really speed up the process, if I boot to desktop and run Netsurf then it'll last about 2 minutes before panicking, HaikuDepot is about 45 seconds and never fully loads. HaikuDepot is also finicky on hrev53092 though.. Sitting at desktop lasted at least 5 minutes until I launched mediaplayer.

Last edited 2 weeks ago by SnodBlatter (previous) (diff)

comment:5 Changed 2 weeks ago by waddlesplash

MediaPlayer picture is actually an app_server crash, not a KDL, so this appears unrelated.

comment:6 Changed 2 weeks ago by waddlesplash

HaikuDepot picture is #14928, so also unrelated.

comment:7 Changed 2 weeks ago by waddlesplash

And the NetSurf picture is also #14928. So, out of all these pictures, only the first one you attached is actually a relevant KDL :)

comment:8 Changed 2 weeks ago by waddlesplash

Component: - GeneralDrivers/TTY
Summary: Panic while sat at desktopNULL dereference in console_write

comment:9 Changed 2 weeks ago by korli

src/bin/consoled/consoled.cpp:	con->console_writer = spawn_thread(&console_writer, "console writer",
src/tests/apps/miniterminal/MiniView.cpp:	fConsoleWriter = spawn_thread(&MiniView::ConsoleWriter, "console writer", B_URGENT_DISPLAY_PRIORITY, this);

comment:10 Changed 2 weeks ago by korli

Component: Drivers/TTYDrivers

Seems like a bug in the console driver.

comment:11 Changed 2 weeks ago by korli

how to reproduce:

sh -c "cat /dev/zero > /dev/console &" ; echo hello > /dev/console

comment:13 Changed 2 weeks ago by waddlesplash

Resolution: fixed
Status: assignedclosed

Fix merged in hrev53237.

Note: See TracTickets for help on using tickets.