Opened 2 years ago

Closed 13 months ago

#15178 closed bug (fixed)

app_server crash on WebPositive

Reported by: roiredxsoto Owned by: axeld
Priority: normal Milestone: Unscheduled
Component: Servers/app_server Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: x86-64

Description

System: Haiku aqvila 1 hrev53242 Jul 11 2019 19:13:24 x86_64 x86_64 Haiku Ryzen 5 2400G + Radeon RX560. Haiku on SSD dual boot with Ubuntu 19.04

Issue: app-server crash on WebPositive.

How to repeat the issue:

  • Open a WebPositive window
  • Go to Flatpak.org
  • Click on Get Setup at the bottom of the page
  • app-server crashes

Added report

Attachments (1)

app_server-755-debug-17-07-2019-17-34-00.report (4.4 KB ) - added by roiredxsoto 2 years ago.
App Server report after crash

Download all attachments as: .zip

Change History (5)

by roiredxsoto, 2 years ago

App Server report after crash

comment:1 by diver, 2 years ago

Confirmed here. Typing bt in console debugger produces no output.

comment:2 by waddlesplash, 2 years ago

Please reproduce and get a KDL backtrace of the thread instead.

comment:3 by Pete, 13 months ago

I think this bug is still present in beta 2 (hrev54154). It has happened to me three times now, at least twice -- maybe always -- when loading a youtube video into W+. The display goes white-screen, and text scrolls down. There seems to be no recovery except the 'off' button. If I try anything else first, all my open folders get squashed into the first Workspace! I think I saw an option in that screen to save a report, but had other priorities. If it happens again I'll try to save something.

My sub-rev is 54154-110, and it was suggested that 54154-115 might contain a fix. However, I'ver been unable to update, and Jason Dodd says he has updated, and it still crashes.

comment:4 by waddlesplash, 13 months ago

Resolution: fixed
Status: newclosed

This specific ticket seems to be fixed, Web+ no longer crashes on that page.

The YouTube crashes are tracked in #15728.

Note: See TracTickets for help on using tickets.